Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have just taken over a Cacti server and am having a nightmare moving from 5 minute polls to 1 minute polls.

So far, I have changed the data template along with the Step (from 300 down to 60) and Heartbeat (from 600 down to 120), and I have also changed the cron job from */5 to */1, and finally, under settings, I have changed the Poller Interval to every minute and cron interval to every minute.

Doing this however seems to cause excessive load on the server along with many errors being added to /var/log/cacti/poller.log (?) about invalid SQL statements and various other issues with RRD.

From my understanding, editing the Data Template does not affect existing RRDs, it simply sets the ones that will be created in the future - and, so, I think the errors are because the RRD files only have steps for 5 minute steps by default instead of the 60 I need.

The most important thing is that existing data is not lost, but, it can be archived if merging is not possible - I have so far attempted to create a second cacti server in order to migrate the existing data (then set them all to disabled), but, this doesn't seem to be working well as I haven't found a good way to import existing RRDs on mass.

I have been spending the past two weeks on this without getting very far and I need some expert help! I was just wondering if anyone has done this before and can offer any advice/what I should be doing in order to migrate over?

share|improve this question
1  
Import the existing RRDs simply by copying the files. Then delete all the RRDs to allow new 1-minute RRDs to be created. –  David Schwartz Nov 1 '12 at 3:45

1 Answer 1

It's not that easy. But if you really want to do this, you need to touch every data-template you are using and set "Step" from 300 seconds (5 minute polling intervall) to 60 seconds. Also, you need to lower Heartbeat from 600 down to 120.

After you made all your changes you need to rebuild Cacti's Poller Cache.

I'm not entirely sure if this will work on existing data, I never tried it. But this is the correct way to do it.

More details are available at "How to configure Cacti for 1-minute polling resolution".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.