Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On a brand new (just unboxed) Dell Precision 7500 computer, I began a kickstart using a red hat boot disk and a kickstart file hosted at an http address.

There is a picture of the full error below with trace information

Kernel panic - not syncing: Fatal exception

I believe this is different than the other questions relating to kernel panic errors.

What I would like to know is

  • What causes the kernel panic

  • How does one fix this such that the kickstart finishes

Additional information can be provided as necessary.

Edit:

This article indicates the problem has to do with using the RHEL6.2 boot disk, and that the issue may be fixed with the RHEL6.3 boot disk.

And it suggests this as the workaround

  1. Plug the NVIDIA GPU adapter card into the system.
  2. Disable the operating system-native GPU driver by appending the kernel parameter "nouveau.modeset=0" as the operating system parameter before kick-starting the install of RHEL6 update 2.
  3. Complete the operating system install and boot to the operating system.
  4. Install the latest NVIDIA driver for the GPU adapter as needed.

To summarize:

  • If you must use RHEL6.2, use "nouveau.modeset=0" on the kernel command line
  • Otherwise, use the latest RHEL6.3 boot disk and this should not be an issue
share|improve this question
    
So, did it work? –  wzzrd Nov 1 '12 at 19:14
    
Yes! I tried this at work today and it did indeed get to the installer and run the kickstart. Thank you! –  mrchampe Nov 2 '12 at 0:03

1 Answer 1

up vote 4 down vote accepted

Your problem (probably) is with nouveau. I have seen this before on machines with Optimus chipsets, but it apparently can also rear it's ugly head on machines that have just NVIDIA hardware.

Try and pass

nouveau.modeset=0 

on the kernel command line when starting the machine.

share|improve this answer
    
Yes, the machine does have an nvidia card and it mentions nouveau at the bottom. How does one pass in that command before the kickstart? –  mrchampe Oct 31 '12 at 18:28
    
@mrchampe Either with a keyboard, or by adding it to your PXE boot options. –  Michael Hampton Oct 31 '12 at 19:42
    
Ok I wasn't sure if it could go "just anywhere" with the other boot parameters. –  mrchampe Oct 31 '12 at 19:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.