Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For emergency in my old machine (CentOS with Xen server) i made clone my LVs with dd

example:

dd if=/dev/vg/lv0 of=/backups/vg_lv0.dd

now in my new machine i've created a LV with the same size

lvcreate -L 6G --name lv0 /dev/vg

and

dd if=/backups/vg_lv0.dd /dev/vg/lv0

with kpartx i can see the partitions inside LV, now i want create a rawdisk for use by virtualbox

vboxmanage internalcommands createrawvmdk -filename /VDK/vg_lv0.vmdk -rawdisk /dev/vg/lv0

when i try to attach the disk to some VM i get: VirtualBox error: The medium '/VDK/vg_lv0.vmdk' can't be used as the requested device type (0x80004005)

i add my user to the disk group the vg_lv0.vmdk has right permissions

What can be causing this error?

my SO: Ubuntu 12.04.1 Server amd64

share|improve this question
    
It sounds like you're trying to attach your disk to the wrong sort of controller. i.e. IDE disk to SCSI/SATA controller or vise-versa. I don't remember if there is a parameter to dictate which type of disk that should be created. –  TheCompWiz Oct 31 '12 at 17:11
    
not. I've tried SATA, SCSI and SAS still I get the same error –  rkmax Oct 31 '12 at 17:15
    
try IDE. You probably have to add the controller. SATA, SCSI and SAS are all treated the same pretty much. –  TheCompWiz Oct 31 '12 at 17:17
    
even with IDE still not working –  rkmax Oct 31 '12 at 17:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.