Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My hosted email server is "Refusing to talk : 550" with my postfix server. Gmail, Yahoo, Hotmail all accepts them fine. All of sudden hosted email provider decided not accept email from my server. I dont really know why... i dont send out spam nor have large volumes.

Anyways, now they want me to get a bounce-back email. All the email in question are in mailq (deferred)

How do I expire them so that postfix will send out "unable to send" to mail clients who sent them?

I dont want to delete them...

Thanks for the help in advance

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Use postqueue -f as root to flush the entire queue; this will cause delivery to be re-tried.

If the remote server really reports a 550, then the messages will not be deferred; they will be rejected, and your postfix server will instantly bounce them.

If this does not seem to be happening, make sure you do not have soft_bounce = yes set:

postconf soft_bounce

On any production server, this setting needs to be off.

share|improve this answer
    
well, messages are in deferred (not bounced). I believe if I set "maximal_queue_lifetime = 30m", and do postqueue -f. postqueue -f will flush and attempt to send/resend messages. So in theory, anything in deferred(queue) longer than 30 min should get bounced. What do you think? –  Philip Rhee Nov 1 '12 at 17:22
    
I couldnt test out maximal_queue_lifetime setting. For now, I've changed email server to relay, then did postqueue -f which did resend the messages. (To be clear, this did not bounce messages. Rather msgs were just relayed to a server which is accepting relay, which forwarded it to my hosted email server) –  Philip Rhee Nov 1 '12 at 17:31
    
Please re-read the above: IF the messages are REJECTED with a 550 status, they will only be deferred IF you have soft_bounce set. –  adaptr Nov 2 '12 at 10:05
    
I didn't mean to question your statement, really... But for my case, mail.log shows "Oct 31 18:04:14 mail1 postfix/smtp[15566]: 901241C0C81: host spam3.ihostexchange.net[66.46.182.94] refused to talk to me: 550 Connection refused" And the same email was in mailq! Anyways... Thank you for your help. –  Philip Rhee Nov 2 '12 at 15:45
    
Then soft_bounce = yes on your server. This is ill-advised. –  adaptr Nov 2 '12 at 19:05
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.