Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had a DC fail on me recently and trying to add a new one to my domain, although I'm sensing I might have other issues in my domain. I'm a dev at heart and know just enough about AD to be dangerous so looking for some assistance.

My working DC is RIVERCITY-DC12. I'm trying to promote RIVERCITY-DC14 as a DC to the RIVERCITY domain, but when I run DCPROMO, at the NETWORK CREDENTIALS step where I point to the name of the domain (rivercity.local), I get "An AD DC for the domain rivercity.local cannot be contacted" and in the details see "The error was DNS name does not exist"

Looking at RIVERCITY-DC12, I can see DNS is working, I've been able to query it from other machines in my domain, and no errors are reported in the DNS category within the Event Viewer. When I checked the FMSO roles, it shows RIVERCITY-DC12 is the machine for all listed roles.

Not sure what I should do next or how to troubleshoot/investigate after searching around for a solution... ideas?

Environment:

  • Domain: rivercity (rivercity.local)
  • Forest functional level: Windows 2000 (I'm more than happy to raise this)
  • Windows Server 2008
  • All servers are Windows Server 2008 R2 SP1 (fully patched)
share|improve this question
1  
What happens when you run nslookup river city.local? Also, is this new DC using other DCs for its DNS? –  MDMarra Nov 1 '12 at 11:10
    
Your question got me thinking... got it working now. Ends up I had the IP settings pointing the primary DNS of the new machine back to itself and the secondary to the RIVERCITY-DC12 machine. Once I switched them around, things worked fine. –  Andrew Connell Nov 1 '12 at 12:54
    
Ideally, what should the DNS configuration be set to on the two DC's? I've always had primary = self and secondary = other DC. –  Andrew Connell Nov 1 '12 at 12:54
1  
@AndrewConnell - That would be the case after running DCPROMO and installing DNS on the new DC, not during DCPROMO. During the DCPROMO process the new DC isn't a DC yet and doesn't have a copy of the AD DNS zone so it can't use itself to find and join the domain. –  joeqwerty Nov 1 '12 at 13:09
2  
@joeqwerty Actually, you never want to point a DC to itself first for DNS. always point it at another domain controller first and have 127.0.0.1 be the last entry in the list, otherwise you might end up with a DC on a replication island in certain circumstances. –  MDMarra Nov 1 '12 at 13:21
add comment

1 Answer 1

up vote 2 down vote accepted

I'm going to go out on a limb and say the the New server isn't configured to use existing DCs for DNS.

share|improve this answer
    
You basically answered the question, I fixed it by updating the DNS on the NIC to point directly to the other DNS which then got stuff working. –  Andrew Connell Nov 1 '12 at 20:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.