Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Using a stand alone Windows Server 2012 Standard edition (no Active Directory),

I Tried to establish a simple remote desktop with a custom port number, but could not modify the port number in the Firewall inbound rule,

when I open the inbound property I get the next message: "This is a predefined rule and some of its properties cannot be modified"

I have tried to set it up like this: New rule -> predifined drop down list -> Remote Desktop -> check mark rules -> Allow the connection.

but still get "This is a predefined rule and some of its properties cannot be modified"

Thank you in advance.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It looks like you're trying to "redefine" a rule for a predefined service when I think you need to make a custom rule for the port you want RDP to listen on. Then you'll need to change thr port that RDP is listening on. Here's an article that explains how to do it in Windows Server 2008 R2. I imagine it's going to be the same in Windows Server 2012.

http://www.techrepublic.com/blog/datacenter/changing-the-rdp-listening-port-on-windows-server/1939

share|improve this answer
    
thank you for the link, I'll check it soon and give my feed back. –  Sami-L Nov 2 '12 at 21:42
    
I have previously changed the port number in the registry, but when I go to the firewall rules I found it unchanged, and no way to change it there. –  Sami-L Nov 2 '12 at 21:48
    
Right, because you're trying to change a rule that uses predefined parameters. Try creating a new port based rule for the port you changed RDP to. –  joeqwerty Nov 2 '12 at 21:50
    
and disable the predefined rule ? there are many in Windows server 2012 that have relation with RDP and its services. I will check now... –  Sami-L Nov 2 '12 at 21:55
    
I have created a new port based rule for the port I changed RDP to and it worked. Previously there was 4 rules using 3389 port RDP TCP, RDP UDP, RDP services TCP, and RDP services UDP, do I have to disable them all? –  Sami-L Nov 2 '12 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.