Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to change the server uplink from 100Mb/s to 1000Mb/s

ethtool eth0 output

    # ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: No
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: yes

ifcfg-eth0 output

cat /etc/sysconfig/network-scripts/ifcfg-eth0
# device: eth0
DEVICE=eth0
BOOTPROTO=static
BROADCAST=10.0.0.1
HWADDR=00:24:21:ef:34:7c
IPADDR=10.0.0.1
NETMASK=255.255.255.255
SCOPE="peer 10.0.0.1"

i execute the command

ethtool -s eth0 speed 1000 duplex full autoneg off

but nothing changed

share|improve this question
    
Is your switch 1gig or 100mbps? If it's 1gig, and it autonegotiated to 100mbps, i'd check the ports and the cable. –  mulaz Nov 1 '12 at 14:38
2  
@iLinux85 Is there a reason auto-negotiate is turned off? –  Chris S Nov 1 '12 at 14:45
    
@ChrisS no there is no reason –  iLinux85 Nov 1 '12 at 14:56
1  
Is there a reason auto negotiation is turned off? The 802.3ab standard requires it be on. –  James Yale Nov 1 '12 at 15:09
1  
Turn auto-negotiation back on and let it do it's job... If your hardware is capable of 1GbE it will run at that speed. –  Chris S Nov 1 '12 at 15:36

1 Answer 1

up vote 3 down vote accepted

You need four things to successfully auto negotiate to a Gbit link.

  1. A NIC capable of that speed. From the output yours seems to be.
  2. A switch capable of handling Gbit. Please check your switch capabilities.
  3. A proper cable, category 5, 5e or 6. If you have older cable (e.g. cat3) then Gbit speeds will (actually: should) not work.
    a) Test this first with a new, known good cable between wall socket and network card.
    b)If that does not fix it, run a cable directly between the NIC and the switch. (If that suddenly works then you got old or improper wiring in your walls, between wall sockets and the switches).
  4. No weird incompatibility problems between NIC and switch. Try the same port you are now using with a different network card (e.g. plug in a laptop with Gbit. See if that negotiates to gigabit link speeds. If it does not then you are likely checking the wrong component.).
share|improve this answer
    
3a. and a properly wired cable, including the portion in the wall. and a cat5 or higher jack on each end. Gigabit Ethernet requires all 4 pairs, and they have to be wired correctly. –  longneck Nov 1 '12 at 15:01
    
Correct. That would have been detected in step 4 when (if) the laptop also failed to get gbit link speeds. But trying a new cable between NIC and wall socket, or between NIC and switch might be less work. I'll add it that to the answer. –  Hennes Nov 1 '12 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.