Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We were in the process of migrating from Exchange 2007 to Exchange 2010 and hit a brick wall when trying to migrate Public Folders.

After resolving issues with connectivity (and another issue with an old Exchange 2003 server being listed in AD that was causing the replication to fail) it finally appeared that messages were migrating from one server to another. However, we appear to have jumped the gun and ran MoveAllReplicas before the process was complete.

We are now stuck with about 210MB of public folders on the new server from a 7GB public folder store on the old server. The messages appear to be available on the old server since running get-publicfolderstatistics shows that there are messages available.

We have waited several days for the move to continue but we are stuck at 210MB. Is there something we can do to complete the replication so that all of the messages move from the old server to the new server?

share|improve this question
    
Can you still see all of your public folders in MS Outlook with an Exchange admin mail profile ? If yes, then do a PST Export of all your public folders from there and import them back into your Exchange 2010. At least you will save your data that way. –  rihatum Nov 5 '12 at 21:30
    
Oops just read your last comment :-) sorry –  rihatum Nov 5 '12 at 21:37
    
@rihatum That's what we ended up doing. After almost three weeks of trying to get this to work correctly, we just decided that this was the most expedient way. Hate using workarounds, but I guess whatever works is best. –  Michael Todd Nov 5 '12 at 21:38
    
true whatever works is best ... Only if outlook could be scripted to export them , one could batch it for the rainy days ... Or if Microsoft could right click export as PST all public folders that would be a life saver too. –  rihatum Nov 5 '12 at 21:47
add comment

3 Answers

I think that if you facing similar type of situation you should directly use a third party tool instead of running the script which might be sometimes wrong to perform. These tools has the ability to solve this problem of migrating more than 7 GB public folders data to the new exchange server 2010.

Thanks

share|improve this answer
add comment

In the Exchange Management Console go to Server Configuration. Right click the server and go to diagnostic. In the Diagnostic Settings go to MS Exchange IS -> Public and enable high logging for all Replication Parts. In the Public Folder Manager click update hierarchy. Now you should see outgoing and incoming ExchangeIS PF Messages in the Eventlog. If you don't see this messages you can you pfdavadmin and exfolders.

http://www.microsoft.com/en-us/download/details.aspx?id=22427

http://gallery.technet.microsoft.com/Exchange-2010-SP1-ExFolders-e6bfd405

share|improve this answer
    
I'm getting a "Could not expand..." error in PFDAVAdmin. I'm downloading .Net 1.1 (per some suggestions elsewhere) to see if that helps. (Oh, and nothing appeared in the event logs when I turned all replication logging on.) –  Michael Todd Nov 1 '12 at 17:04
    
Installing .Net 1.1 and running PFDAVAdmin in XP compatibility mode worked. However, all that seems to allow me to do is view what I can already see in Exchange Management Console and the Public Folders tool; the messages are there, the replications appear to be set, but nothing is happening. Any other thoughts? –  Michael Todd Nov 1 '12 at 17:38
    
with pfdavadmin you can remove item-level permissions. with remove item-level permission you initiate a full replication. then look into the eventlog for the messages –  user1008764 Nov 1 '12 at 19:53
    
I'm definitely seeing non-error messages in the event log related to replication but the messages still aren't appearing on the new server. Very odd. –  Michael Todd Nov 2 '12 at 16:13
    
None of the items had item-level permissions enabled. I removed them anyway (just in case), but still nothing happened. We decided that we'd worked long enough trying to do this the "right way" so we just copied the public folders over via PST. Thanks for your help, though. –  Michael Todd Nov 5 '12 at 21:21
add comment

Although this is more of a workaround, I'll post it in case others run into this issue in the future.

We were never able to get communication to work correctly between Exchange 2007 and 2010 in regards to Public Folders.

After trying for about three weeks to resolve this we simply copied the entire set of public folders to a PST in Outlook via a user connected only to Exchange 2007. We then switched to a user on Exchange 2010 and populated the folders. It was only about 7.5 GB of data so it went fairly quickly, though all users reported non-responsive Outlook clients while we were performing the move.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.