Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When i try to install or update any packages I get:

Untrusted packages could compromise your system's security. You should only proceed with the installation if you are certain that this is what you want to do.

I strongly suspect this is related to the error i get on update:

$ sudo aptitude update
Get: 1 http://ftp.us.debian.org wheezy InRelease [208 kB]
Get: 2 http://debian.lcs.mit.edu wheezy InRelease [208 kB]
Ign http://ftp.us.debian.org wheezy InRelease
Hit http://ftp.us.debian.org wheezy/main amd64 Packages/DiffIndex
Hit http://ftp.us.debian.org wheezy/contrib amd64 Packages/DiffIndex
Hit http://ftp.us.debian.org wheezy/non-free amd64 Packages/DiffIndex
Hit http://ftp.us.debian.org wheezy/contrib Translation-en
Hit http://ftp.us.debian.org wheezy/main Translation-en
Hit http://ftp.us.debian.org wheezy/non-free Translation-en
Get: 3 http://debian.lcs.mit.edu wheezy-updates InRelease [116 kB]
Ign http://debian.lcs.mit.edu wheezy InRelease
Ign http://debian.lcs.mit.edu wheezy-updates InRelease
Hit http://debian.lcs.mit.edu wheezy/main Sources/DiffIndex
Hit http://debian.lcs.mit.edu wheezy/main amd64 Packages/DiffIndex
Hit http://debian.lcs.mit.edu wheezy/main Translation-en
Ign http://ftp.us.debian.org wheezy/contrib Translation-en_US
Ign http://debian.lcs.mit.edu wheezy-updates/main Sources/DiffIndex
Ign http://debian.lcs.mit.edu wheezy-updates/main amd64 Packages/DiffIndex
Ign http://ftp.us.debian.org wheezy/main Translation-en_US
Ign http://ftp.us.debian.org wheezy/non-free Translation-en_US
Hit http://debian.lcs.mit.edu wheezy-updates/main Sources
Hit http://debian.lcs.mit.edu wheezy-updates/main amd64 Packages
Ign http://debian.lcs.mit.edu wheezy/main Translation-en_US
Ign http://debian.lcs.mit.edu wheezy-updates/main Translation-en_US
Ign http://debian.lcs.mit.edu wheezy-updates/main Translation-en
Fetched 531 kB in 1s (304 kB/s)
W: GPG error: http://ftp.us.debian.org wheezy InRelease: Unknown error executing gpgv
W: GPG error: http://debian.lcs.mit.edu wheezy InRelease: Unknown error executing gpgv
W: GPG error: http://debian.lcs.mit.edu wheezy-updates InRelease: Unknown error executing gpgv

I have tried reinstalling the key ring: sudo aptitude reinstall debian-archive-keyring (which surprisingly doesn't cause a warning).

share|improve this question
    
Possibly related: askubuntu.com/a/64544/284919 –  kasperd Oct 13 at 9:25

3 Answers 3

Try this please:

Open a terminal and run the following commands:

sudo apt-get clean
sudo rm -rf /var/lib/apt/lists/*
sudo rm -rf /var/lib/apt/lists/partial/*
sudo apt-get clean
sudo apt-get update
share|improve this answer
    
you don't reallly think I've just been ignoring this issue for 16 months do you? I'm not sure if this would work because I don't see the problem any more. I probably just rebuilt but I'm not sure as I don't even remember which machine it was. –  user1794469 Jan 31 at 0:12
3  
@user1794469. This site is supposed to be a useful to everyone, not just you. As such, late answers to unanswered questions are perfectly acceptable, as they may help others. That said, this answer would be better quality if it sought to explain what those commands do. –  TRiG Jul 8 at 14:23
    
This worked for me on squeeze. Thanks. :) –  bennettp123 2 days ago

You seem to be hit by Debian bug #657561. You can try to move problematic /var/lib/apt/lists/*InRelease files and rerun apt-get update.

share|improve this answer
    
Nope, i knew there was one more thing i had tried... I did rm -r /var/lib/apt/lists/* –  user1794469 Nov 2 '12 at 18:26
    
Any more ideas? –  user1794469 Nov 6 '12 at 15:35

After reading APZ's answer, but wanting to use aptitude I executed with success the following commands:

# clean the obsolete cache
sudo aptitude clean
# update the package information
sudo aptitude update
# install or upgrade the packages
sudo aptitude install <list of packages to upgrade/install>

The error is probably related to obsolete apt cache contents, but the error message I got was a bit different:

WARNING: untrusted versions of the following packages will be installed!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.