Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am hosting a staging site ( which currently work well on port 80 for two sites ( and

I am working on a new backend and I would like to deploy a third site on this server for testing. My hope is that it will live at I've got some experience with apache and quickly added statements:
Listen 4204
NameVirtualHost *:4204

and created a new config for my site. What I imagine are the relevant parts of my config:

<VirtualHost *:4204 >

However, the site is not publicly available, by name or ip. If i

curl localhost:4204

from the server, I get the expected page content

At this point, I'm a bit of a loss on how to go forwards. It seems like my config is correct but not available to be served. Am I better off defining a proxy definition so that, for instance:

proxies to my localhost server or is there a way to make the site available via the internet?

I have added an iptable rule after further Googling with the command:

iptables -I INPUT -p tcp --dport 4204 -j ACCEPT

I can see apache listening on 4204 and the rule is definitely in place but cant reach the site

share|improve this question
up vote 1 down vote accepted





The first line in your example is specifying the port so you don't have to do it again.

share|improve this answer
I have done so and restarted apache, but no change :( – user1026361 Nov 2 '12 at 17:39
Can you post the complete virtual host settings? – dkwiebe Nov 2 '12 at 21:17
Sorry guys....looks like my config was good. The hosting provider had to open a port for me. – user1026361 Nov 5 '12 at 19:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.