Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using a stand alone Windows Server 2012 Standard edition (no Active Directory),

I succeded to add a new rule to allow sql server connection, by entering the .exe file

When I edited the rule property to specify the port number, text zones for ports are greyed and no way to write in them.

Is there a new feature in Windows Server 2012 that by default disables port numbers editing ?

Any advices please ?

share|improve this question
    
Are you using static or dynamic ports with SQL Server? –  joeqwerty Nov 2 '12 at 18:13
add comment

2 Answers

up vote 0 down vote accepted

It sounds like you've got SQL Server configured to listen on a specific port but you're trying to create a program based firewall rule (which is used when SQL Server is configured to use dynamic ports). If SQL Server is in fact configured to use a static port (such as the default TCP port 1433) then you need to create a port based firewall rule.

share|improve this answer
    
Yes, your answer is right, I was trying to give specify a port number different than the default one, and to allow only a given dynamic port number, not static. I was confused because I had to do that in SQL Server settings not firewall. Now both of you Joequerty and August gave right answer two hours ago, and I need to mark as an answer the first one responding, which one is the first ? –  Sami-L Nov 2 '12 at 21:31
    
My answer is an hour older, so it was first. :) –  joeqwerty Nov 2 '12 at 21:32
    
could you please help me on this : serverfault.com/questions/444339/… –  Sami-L Nov 2 '12 at 21:33
add comment

"I succeded to add a new rule to allow sql server connection, by entering the .exe file"

I have zero experience with Server 2012, but if it is anything like 2008 R2, then when you specify a program to allow through the firewall, Windows will let traffic through no matter what port that exe is listening on. Once you specify that the rule is for a program, then the port option becomes grayed out. That might explain why you can't specify the port in the rule explicitly. Are you having issues connecting to the SQL server remotely?

share|improve this answer
    
I wish I could up vote your answer, I have not enough score to do that. Could you please help me on this : serverfault.com/questions/444339/… –  Sami-L Nov 2 '12 at 21:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.