Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a SmokePing FTPtransfer graph but with no luck. I have the ping graphs all figured out but the FTP graph is just empty. Here is my Probes config:

*** Probes ***

+ FPing

binary = /usr/bin/fping

+ FTPtransfer
destfile = /home/bunny/speed.speed
forks = 1
min_interval = 1
mode = get
offset = 50%
srcfile = ftp.sunet.se/pub/FreeBSD/releases/i386/ISO-IMAGES/8.3/FreeBSD-8.3-RELEASE-i386-bootonly.iso
step = 60
timeout = 180 # mandatory

And here is the Target config:

*** Targets ***

probe = FPing

+ FTP
probe = FTPtransfer
menu = FTP
title = FTP 52MB file from ftp.sunet.se
host = ftp.sunet.se
localaddr = myhost-nat-if
username = user
password = password
pings = 5

The graph is showing on my page but does not get filled with the time to complete the transfer. The FTP-server does not require any password or username, tho I've tried with user:password and that works fine.

If anyone got this Probe set up and working I would love to take a look at your Probes and Targets config.

Any help is appreciated.

share|improve this question

1 Answer 1

Have you tried using passive mode? Set passive mode with:

passive = yes

My next challange is figuring out/configuring where smokeping stores the retrieved files. Seems to me like it is not saved in the data directory but wherever you start smokeping from.

share|improve this answer
    
FTP file storage solved by using "destfile" directive –  Arne Aug 1 '13 at 10:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.