Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know this question has been asked many times (here and on TechNet), and the answer is usually "use RDP". But apparently, RDP is now the only option, and it's what I'm using.

My screen is an LCD TV with a resolution of 1360x768. Unfortunately, this resolution is apparently not supported; the closest I can get in a Windows 8 VM is 1366x768, and it adds scrollbars, which make it difficult to put the mouse in the corners to get at the start screen and charm bar... Smaller resolutions don't fill the screen, so it's also difficult to put the mouse in the corner.

Is there a way to set a custom resolution to fit my screen exactly ?

(note: I know it's not a Windows 8 problem, since I don't have this problem on my host machine which also runs Windows 8. I assume it's related to the display adapter used by Hyper-V, but there don't seem to be any options to change it)

share|improve this question
up vote 4 down vote accepted

Try opening the RDP session at the command line, specifying exactly the resolution that you want:

mstsc /v:WIN8_VM_HOSTNAME /w:1360 /h:768

Another approach that should match the local desktop size exactly, assuming that the LCD TV is your only monitor on the client machine, is as follows:

mstsc /v:WIN8_VM_HOSTNAME /span

If you want the RDP session to launch in full screen mode, add /f to the end of the command.

share|improve this answer
It works, thanks! Actually I thought I was using mstsc because it looked exactly the same and the connection info mentioned Remote Desktop, but it was actually vmconnect.exe. With I don't even need to specify the resolution on the command line, it works fine with no arguments. – Thomas Levesque Nov 2 '12 at 21:47
RDP via mstsc.exe will unfortunately not work if you have to use a VPN connection within the VM. The VPN stops all network connections and therefore a RDP connection fails. I do not understand why there is a limit of the screen resolution of the Hyper-V "Virtual Machine Connection" window. I would really appreciate fixing this limitation. – user170748 Apr 23 '13 at 5:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.