Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hey guys i just installed cacti on a ubuntu 12.04 server and am having issues with any data showing up on my graphs.

If i snmpwalk the certain OID it works. I have tailing on the cacti.log file and i see it polling the values correctly but nothing ever graphs.

Is there anything i can check with regards to snmp or something in cacti that may be causing this to not work?

I have already checked in my php.ini and have set the timezone, someone was mentioning that may cause issues.

CACTI LOG FILE

UPDATE: added cacti log file

share|improve this question
    
Did you check "System Utilities -> View Cacti Log File"? What does it say? Is the SNMP community and version correct? Is the Cacti host in the ACL of the SNMP-host you want to query? What data do you want to query? Is the graph-template approriate for your type of host? –  Alexander Janssen Nov 2 '12 at 22:10
    
from what i know the device is in the ACL, the template is appropriate. When i manually snmpwalk with the same settings it works. I will post a log file of the cacti log to show whats going on –  Dani Cela Nov 3 '12 at 0:23
    
Did you check Cacti's logfiles at "System Utilities -> View Cacti Log File"? Raise loglevel if needed. –  Alexander Janssen Nov 3 '12 at 0:24
    
yep i did, i just posted the file and its on debug mode. –  Dani Cela Nov 3 '12 at 0:26
    
How does your crontab poller.php entry look like? Do you run it every 5 minutes? –  Alexander Janssen Nov 3 '12 at 0:33
show 4 more comments

1 Answer

up vote 1 down vote accepted

According to your logfiles, you changed the "Poller Interval" in Cacti from the default of "Every 5 Minutes" to "Every 10 Seconds".

The Cacti settings say:

Poller Interval

The polling interval in use. This setting will effect how often rrd's are checked and updated. NOTE: If you change this value, you must re-populate the poller cache. Failure to do so, may result in lost data.

This won't work unless you also change it in the system's cronjob!

Also we have the cron-interval, just below of it in the settings:

Cron Interval

The cron interval in use. You need to set this setting to the interval that your cron or scheduled task is currently running.

So, the question is: Do you really need 10-seconds sampling? REALLY? If not, revert everything to "Every 5 Minutes" and then go to "System Utilities -> Rebuild Poller Cache".

Restart cron, in case you made it not be be 5 minutes, and wait for 15 minutes. Graphs should be appearing then.

EDIT: Just saw your reply. Do not change crontab, it's ok.

Go to: "Settings -> Poller":
Set: Poller Interval = Every 5 Minutes
Set: Cron Interval = Every 5 Minutes
Save
Go to: "System Utilities":
Run "Rebuild Poller Cache"

Do not fiddle around with intervals if you don't need to.

share|improve this answer
    
ok sounds good, i have changed them back to 5min and i will let you know how it goes. Thanks for your help! –  Dani Cela Nov 3 '12 at 0:51
    
if i wanted to change it to 1min interval, i modified the crontab to 1 and i changed my polling setting and my cron settings to 1. I restarted cron, and i rebuild poller cache. What could be causing the issue now? –  Dani Cela Nov 3 '12 at 1:31
2  
Change evervything to 5. If that works, you can try another setting. You need to adaot data tempate for it. –  Alexander Janssen Nov 3 '12 at 1:46
    
ok i have everything at 5 min and it is working. I guess i dont need it at 1 minute, but if i wanted to what would be the steps now? –  Dani Cela Nov 3 '12 at 2:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.