Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

installed squid + dansguardian to block adult content on my linux (ubuntu 12.10) . everything worked fine. it has blocked as expected . now the problem is i am also running an apache server for my LAN . ( kind of website ) but when accessing it via 192.168.0.1 , it says squid has blocked the connection , this is the exact error

The following error was encountered while trying to retrieve the URL: http: //192.168.0.16/

Connection to 192.168.0.16 failed.

The system returned: (113) No route to host

The remote host or network may be down. Please try the request again.

Your cache administrator is webmaster.

before configuring the squid it was working fine . what changes in the squid.conf i have to make . i tried

   acl Safe_ports 80

   allow_all Safe_ports

( i want to know how i can configure it again to listen HTTP request from LAN )

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

"No route to host" suggests that something else happened while you were configuring Squid. If you log into the machine running Squid (presumably 192.168.0.1), can you ping 192.168.0.16 from there?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.