Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First, my server only has two public IP addresses.

eth1   188.138.124.244 netmask 255.255.255.192 
eth1:0 85.25.110.198 netmask 255.255.255.192 
default gateway: 188.138.124.193

How can I set up VirtualBox so that the Guest can be a server and use the 85.25.110.198?

When I attempt to setup bridged networking, it doesn't seem to work at all.

share|improve this question

closed as off topic by MDMarra, joeqwerty, Chopper3, Scott Pack, sysadmin1138 Nov 4 '12 at 2:20

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
OK why the downvote? I've been struggling with this problem going on 6 hours now. I've scoured the Internet. –  hopeseekr Nov 3 '12 at 18:42
1  
I didn't downvote you but I'm going to guess it's because this is a site for professional sysadmins and your question is staggeringly basic, it's also got little, if anything at all, to do with the server being a VM, that VM running on VB and I have no idea why you've added KVM to your tags either. –  Chopper3 Nov 3 '12 at 18:54
    
@Chopper3 My question was very precise and few details were needed, in my mind. It was how to set up VirtualBox to use two different subnets. An unknown mitigating circumstance was that the ISP filtered by MAC address, which is why it wouldn't work (thanks, pino42!). –  hopeseekr Nov 3 '12 at 20:19
    
OK I don't understand. This is a SERVER issue. I'm trying to run a headless VirtualBox on a DEDICATED server with PUBLIC IPs on DIFFERENT subnets. This isn't a problem ANY home user would EVER run into. How can it possibly be off-topic with regard to servers?? –  hopeseekr Nov 4 '12 at 3:32

1 Answer 1

up vote 1 down vote accepted

If your provider does not filter your packets by MAC address, you could try removing eth1:0 altogether from your host configuration and setting its public IP address only in your guest operating system. If it does filter by MAC address, chances are bridged networking won't cut it; perhaps in that case you'd be better off using NAT networking and setting the necessary port forward rules.

share|improve this answer
    
Any idea why the question was marked off-topic? It's 100% dedicated server-related... –  hopeseekr Nov 4 '12 at 3:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.