Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to send an E-Mail to some stricter set up MXs I get:

<local_hostname>: Helo command rejected: need fully-qualified hostname (in reply 
to RCPT TO command)

Of course, when setting $myhostname in main.cf the Mail gets delivered correctly, but that brings me into conflict with my default virtual hostname being the hostname of the Box itself, and the incoming mails to hostname.org are treated as to be delivered by the LDA, eg. to "local_hostname"

$myorigin and $mydomain didnt seem to change the HELO response either, any suggestions?

share|improve this question
add comment

2 Answers

From an edit to the original question:

http://www.linuxquestions.org/questions/linux-server-73/how-to-map-local-addresses-to-fqdn-addresses-with-postfix-894863/ setting mydestination to " " and then changing $myhostname to the FQDN solved the Problem.

share|improve this answer
    
Setting $myhostname to the FQDN worked for me. –  rsuarez May 26 at 14:14
add comment

It has taken me ages to work this out

I am running a centos server and was getting email bouncing back reporting the error" Helo command rejected: need fully-qualified hostname"

I ended up enabling "Reference /etc/mailhelo for outgoing SMTP HELO [?]" This was located under "exim configuration manager" then "Domains and IPS" on the VPS server

Then i used putty and remoted onto the server and ran this command "sudo nano /etc/mailhelo"

In that file i created the domains

example.com: example.com
sub.example.com: example.com
example.net: example.net
addon.example.net: example.net
*: hostname.example.com

(as per http://docs.cpanel.net/twiki/bin/view/AllDocumentation/WHMDocs/EximDifferentIps)

I have tested sending email and all looks good so far

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.