Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a cluster farm that I'm setting up.

The nodes (computers in the farm) are connected via ethernet & IP over Infiniband. I'm needing to netboot the nodes and thought dnsmasq would fit well as it provides all the features including support for DHCP over IB and it works great for our ethernet setup. However, I can't seem to get it to provide IP addresses to the infiniband adaptors on the nodes.

Each node is running an Ubuntu desktop 12.04 LTS. The dnsmasq server is running on ubuntu server 12.04LTS and has the following test config:

dhcp-authoritative
domain-needed
bogus-priv
expand-hosts
no-hosts
domain=local

dhcp-range=eth0,10.0.0.10,10.0.0.255,12h
dhcp-option=eth0,3,10.0.0.1

dhcp-range=ib0,10.1.1.10,10.1.1.255,12h   
dhcp-option=ib0,3,10.1.1.1

log-queries
log-dhcp

IPoIB works between nodes when configured statically but not with dhcp. On the nodes the file /etc/network/interfaces contains

auto lo
iface lo inet loopback

auto ib0
iface ib0 inet dhcp
#iface ib0 inet static
#address 10.1.1.5
#netmask 255.0.0.0
up echo connected >`find /sys -name mode | grep ib0`

Is there something I need to do on the client or server end to make this work?

share|improve this question
    
I found out that the client also needs to support the DHCP over infiniband. Windows dhcp client appears not to support it. Therefore I gave up on the persuit and am using static assignment. –  Matt Sep 4 '13 at 1:35
    
Did you find a solution to this? I'm getting into the exactly the same question right now... –  Danduk82 Feb 5 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.