Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Long story short: I've inherited a hellish amount of PHP code (framework) highly dependent on package versions.

The problem is that I need a PHP version >=5.3.0 and <=5.3.3 for CentOS 5.7 i386, which I can't seem to find anywhere - not even source code.

Only thing I've found is this , but it's for 64bit.

Also if upgrade PHP from 5.2.17 to a version between 5.3.0 and 5.3.3 will it break any PECL extensions I've compiled already?

Thanks in advance!

share|improve this question
up vote 4 down vote accepted

With respect, I don't think you can have looked very hard if you couldn't find the source code to PHP 5.3.0-5.3.3, since they're all available from's releases page.

As for RPMs, or even SRPMs, that's a different matter. I personally turn around to my developers and bark at them if they look like trying to tie me in to any version of anything that's not supported on the base OS, so I don't have any pointers myself. Keep looking, is the only real advice I can give you there. Sorry.

share|improve this answer
I swear I didn't see the versions there... probably stopped scrolling when I saw 5.2.17 (5.3.3 is 3 versions below...) my bad! As for the original developers - they are trying, with all their might, to keep the project with them and milk the client hard, while he tries to adopt it's development in-house. Obviously, they won't cooperate. The second question, concerning my existing compiled extensions still stands. – Alexander Ivanov Nov 5 '12 at 14:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.