Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to remotely manage Hyper V server 2012 from a windows 8 pc, both client and server are on a workgroup.

I've spent about 3-4 hours trying to get this working with no luck so far trying the following:

  1. Creating a new administrator on the server with the same details as the client ie. username / password.

  2. Add an entry into my hosts file to point to the remote ip by server name.

  3. Tried using HVRemote.

  4. Disabled both firewalls.

The error that I'm getting is RPC Service Unavailable.

How can I accomplish what I'm trying to do?


Update

Some of the operations on the Hyper-V Manager work. IE. Virtual Switch Works. I can open the New VM Wizard. I run into an error when creating a new Virtual Hard Disk tho. I've tried creating a VM without a hard disk, which works. Using the new hard disk wizard does not work either.

I still can not see any Virtual Machines. RPC server unavailable. Unable to establish communication between 'ServerName' and 'ClientName'


Update 2

Here's a screen shoot of my error. enter image description here

share|improve this question
    
Can you open administrative shares on the servers (eg \\server\c$) without being prompted for credentials? –  Chris S Nov 5 '12 at 14:10
    
can you telnet to port 445 from your workstation. –  tony roth Nov 5 '12 at 15:28
    
@Chris S Yes I can. I can also manage services through the computer management when connecting to the computer. I can't access the disk management tho –  Chris Kolenko Nov 6 '12 at 0:35
    
@tony roth Will check that tonight. –  Chris Kolenko Nov 6 '12 at 0:36
    
hmm suspect telneting to 445 works if you can manage services. –  tony roth Nov 6 '12 at 14:40

3 Answers 3

  1. Enable remote management, on the server
  2. Enable local admin account, on the server
  3. Add matching admin account, on the client
  4. Allow MMC & WMI through the Windows Firewall, on both

    netsh advfirewall firewall add rule name="Microsoft Management Console" dir=in action=allow program="%windir%\system32\mmc.exe" enable=yes profile=private

    netsh advfirewall firewall set rule group="Windows Management Instrumentation (WMI)" new enable=yes

  5. Allow Annoymous DCOM Access, on the client

    1. DCOMCNFG
    2. Console Root > Component Services > Computers > My Computer
    3. Right click > Properties > "COM Security"
    4. Edit Limits under Access Permissions
    5. Check "ANONYMOUS LOGON" under Remote Access

Directions from: http://publicjotting.blogspot.com/2012/06/hyper-v-server-2012-and-remote-hyper-v.html & http://technet.microsoft.com/en-us/library/jj647788.aspx

share|improve this answer

It's an UAC issue. In a workgroup environment you must use the built-in Administrator account on the hyper-v host since WMI can't elevate a regular Administrator account.

There are only three way to run a WMI script elevated.

Running it from a elevated cmd/powershell prompt. Scheduling it to run in a administrator account context (any administrator account). Use the built-in Administrator account (which always run elevated).

Ie, creating a matching user on the server and putting it in the Administrators group is not enough since you can't elevate your account WMI will regard it as a regular user account and fail your request.

I wrote a pretty extensive blog post on how and why.

http://blog.plausibledeniability.se/post/33464344054/hyper-v-remote-administration

My preferred solution (TLDR)

  1. Install RSAT on Windows 8
  2. Enable the Hyper-V tools Add the Hyper-V host to the Server Manager on the client
  3. Set the hosts built-in local Administrator account as the “Manage as” account (right click the server in Server manager and use hostservernetbiosname\administrator as username)
  4. Launch the Hyper-V Manager from the Server Manager (right click)
  5. Profit

You still need to open up the firewall for incoming WMI management on the Hyper-V host and add the ANONYMOUS LOGON group to the “Distributed COM Users” group or update the CINOM registry setting to allow anonymous callbacks, on the client.

share|improve this answer
  • Hold down the Shift key while right clicking on the Hyper-V Remote Manager
  • Select from the right-click menu "Run as different user"
  • For the user name input the computer name of the Hyper-V server and then a backslash fallowed by the user name (exp. server\user)
  • Input the users password and hit Ok.
share|improve this answer
    
Do i have to create a new user on the client machine for this to work? –  Chris Kolenko Nov 8 '12 at 2:37
    
No, it has to be a user, in the domain that the Hyper-V server is in, with rights to access the Hyper-V server or a user on the Hyper-V server. –  Sane Nov 8 '12 at 2:42
    
Tried runas /netonly /user:ServerName\ServerUsername "C:\system32\mmc.exe" Still getting the same error –  Chris Kolenko Nov 8 '12 at 2:43
    
Both client and server are workgroup –  Chris Kolenko Nov 8 '12 at 2:44
    
Try doing the above trick with the Hyper-V Remote Manager shortcut in the Administrator Tools and see if it works. –  Sane Nov 8 '12 at 2:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.