Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I cannot connect to my local SQL Server Express (2012, but the version shouldn't matter) from my server (Windows 2008 R2) to use a tool on it (APEX SQL Data Diff if you are wondering). I can browse the network servers fine, and select my local instance from the dropdown of available servers, but when I go to search tables on the server, it times out with this error message (same is true of SSMS).

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 28 - Server doesn't support strong text requested protocol) (Microsoft SQL Server, Error: -1)

I have enabled the firewall - that's not it.

I have allowed remote connections - that's not it.

SQL Server Browser service is on and passed through the firewall - that's not it.

I can connect fine with the same tools TO the server, but FROM the server it fails.

Any ideas?

share|improve this question
    
Please mark your answer as an answer if this has solved your question. –  Bernie White Nov 5 '12 at 19:21
    
@BernieWhite, I am not allowed to for another 22 hrs... and I thought by adding the question with an answer it would do that automatically... apparently not. This whole comment discussion belongs in (meta.serverfault.com) anyway. –  Watki02 Nov 6 '12 at 20:13

1 Answer 1

up vote 0 down vote accepted

There doesn't seem to be another Stack Exchange entry on this, and no one captures the issue completely, so here it goes.

Thanks to this article for getting me somewhere with the error message. The issue is the necessary network protocols are disabled by default in SQL Server Express. I had to go to Sql Server Configuration Manager locally and turn on "Named Pipes" and "TCP/IP".

SQL Server Config manager

Hope this helps someone else!

share|improve this answer
1  
I don't think your screen shot is accurate. SQLEXPRESS disables this by default but on the protocol for the instance, not the client. –  Jason Cumberland Nov 6 '12 at 17:57
    
@JasonCumberland, you are right. This is the screenshot after I corrected them. –  Watki02 Nov 6 '12 at 20:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.