Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to figure out how to add a network route, and I keep getting "The route addition failed: The parameter is incorrect." I have even tried the example from the route command help, and I get the same error. Here are my current routes:

===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 13 a9 28 48 ce ...... Intel(R) PRO/100 VE Network Connection - Packet Scheduler Miniport
0x3 ...00 18 de 09 da ee ...... Intel(R) PRO/Wireless 3945ABG Network Connection - Packet Scheduler Miniport
0x4 ...00 13 a9 13 16 41 ...... Intel(R) PRO/1000 PL Network Connection - Packet Scheduler Miniport
0x10006 ...00 16 fe 95 84 2d ...... Bluetooth Personal Area Network from TOSHIBA - Packet Scheduler Miniport
0x40007 ...00 05 9a 3c 78 00 ...... Cisco Systems VPN Adapter - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
      0.0.0.0          0.0.0.0      192.168.1.1    192.168.1.50       25
     10.0.0.0        255.0.0.0      192.168.5.1    192.168.5.56       1
 74.93.48.189  255.255.255.255      192.168.1.1    192.168.1.50       1
    127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
  169.254.0.0      255.255.0.0     192.168.1.50    192.168.1.50       20
  192.168.1.0    255.255.255.0     192.168.1.50    192.168.1.50       25
 192.168.1.50  255.255.255.255        127.0.0.1       127.0.0.1       25
192.168.1.255  255.255.255.255     192.168.1.50    192.168.1.50       25
  192.168.5.0    255.255.255.0     192.168.5.56    192.168.5.56       25
 192.168.5.56  255.255.255.255        127.0.0.1       127.0.0.1       25
192.168.5.255  255.255.255.255     192.168.5.56    192.168.5.56       25
    224.0.0.0        240.0.0.0     192.168.1.50    192.168.1.50       25
    224.0.0.0        240.0.0.0     192.168.5.56    192.168.5.56       25
255.255.255.255  255.255.255.255     192.168.1.50               4       1
255.255.255.255  255.255.255.255     192.168.1.50    192.168.1.50       1
255.255.255.255  255.255.255.255     192.168.1.50               2       1
255.255.255.255  255.255.255.255     192.168.1.50           10006       1
255.255.255.255  255.255.255.255     192.168.5.56    192.168.5.56       1
Default Gateway:       192.168.1.1
===========================================================================
Persistent Routes:
  None

I'm just trying the example command right now, and even that doesn't work:

route ADD 157.0.0.0 MASK 255.0.0.0 157.55.80.1 METRIC 3 IF 2 The route addition failed: The parameter is incorrect.

share|improve this question
add comment

1 Answer

It turns out I needed to add an IP in the right subnet to the adapter first. I added 157.1.2.3 to the adapter, and then the route add worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.