Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Disclaimer: I'm totally new to Fink.

I'm trying to install Octave (Matlab open source clone) on Mountain Lion using Fink, following instructions at http://wiki.octave.org/Octave_for_MacOS_X It's a new installation of Fink, and I've also installed X11 per instructions.

I'm using this command (which I believe is correct since everything's 64 bit now):

sudo fink install octave-atlas

It's hanging after a while, showing this as it's last output:

Setting up xft2-dev (2.2.0-2) ...
Clearing dependency_libs of .la files being installed

Reading buildlock packages...
    All buildlocks accounted for.
/sw/bin/dpkg-lockwait -i /sw/fink/dists/stable/main/binary-darwin-x86_64/x11/xinitrc_1.5-1_darwin-x86_64.deb
(Reading database ... 14871 files and directories currently installed.)
Preparing to replace xinitrc 1.5-1 (using .../xinitrc_1.5-1_darwin-x86_64.deb) ...
Unpacking replacement xinitrc ...
Setting up xinitrc (1.5-1) ...

I did notice the process name on the terminal's tab was "sort", so the second time I hit this I tried Control-D (End-of-File), and this did seem to unstick it. I'm wondering if there's some misformed command and sort was trying to read from stdin?


1: Has anybody else seen this? Google wasn't helpful

2: Fink outputs a LOT of warnings and errors.... is that normal?

3: wondering if anybody's got Fink to compile Octave on Mountain Lion specifically? And whether they used just "octave" or "octave-atlas". Or if you got it working with MacPorts or Homebrew?

4: later Fink failed with "Failed: phase compiling: gnuplot-minimal-4.6.1-1 failed". I haven't started googling that yet... but wondering if anybody's see that?

Also tried MacPorts but got other errors with Octave.

And reading online it looks like HomeBrew also has issues with Octave on Mountain Lion.

5: Generally looking for anybody who's got Octave running on Mountain Lion with any of the package managers. I've been at this for a couple days ;-)

share|improve this question

closed as off topic by Shane Madden, Ward, Michael Hampton, Scott Pack, sysadmin1138 Nov 6 '12 at 20:29

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

I thought package managers and compiling were "on topic". Anyway, in case anybody else hits this, the other two changes: chose fink octave instead of octave-atlas, and when it prompts for various package choices, I later chose NOT the default for gnuplot-simple, but instead just gnu plot (maybe #8 or something) –  Mark Bennett Nov 7 '12 at 2:36