Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I gzipped a folder in an old server that included all of the sites served. That server does not exist anymore and I needed some info from the backup but when I extract the backup (a 26GB file) I only get a 28GB blank file that says "Document" under OSX and no program says it's corrupted or anything. Could I recover any info inside this file or is it a lost cause? I tried anyways everything listed here and got the same result.

share|improve this question

1 Answer 1

Well, gzip is a pure compression tool. It cannot archive a folder on its own. So what you most probably did is you created a gzipped tarball (via tar czf file.tar.gz folder). To unpack it, you need to tell tar to unpack it: tar xzf file.tar.gz or if you already unpacked the file with gzip you can call tar xf file.tar.

share|improve this answer
    
I get these errors when I tried the commands you mentioned on either the original file or the extracted result tar: Unrecognized archive format tar: Error exit delayed from previous errors. –  actionAxolot Nov 6 '12 at 19:43
    
This is what the file command tells me about the file backupaugust.gz: gzip compressed data, was "phpinfo.php", from Unix, last modified: Tue Feb 22 14:55:42 2011 –  actionAxolot Nov 6 '12 at 19:45
    
And what does file say about the unzipped "Document"? –  zhenech Nov 7 '12 at 7:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.