Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

xen 4.1.2 is running with ubuntu 12.04 as dom0.

I need to enable networking between vm only(which means not creating a bridge between Ethernet card and sharing among vm).

when i installed virt-manager i am able to see a bridge virbr, with network 192.168.122.0 but i dont want to use virt-manager for creating virtualbridge.

Is there a way to create virtual bridge and tell vm to use this virtual bridge rather than creating a bridge with ethernet interface and sharing among vm.

Installed bridge utilities but virbr is not showing up.

can any one know how to create virbr without installing virt-managetr

share|improve this question

2 Answers 2

up vote 2 down vote accepted

install bridge-utils and then specify this in /etc/network/interfaces (in ubuntu)

auto virbr0
iface virbr0 inet static
bridge_ports none
address 192.168.122.1
netmask 255.255.255.0

and then restart network. Specify this (virbr0) bridge in vm configuration file.Start VM.

share|improve this answer
ip tuntap add mode tap user your_username dev tap0
ip tuntap add mode tap user your_username dev tap1
ip link set dev tap0 up
ip link set dev tap1 up
brctl addbr br0
brctl addif tap0
brctl addif tap1
ip link set dev br0 up
ip addr add 192.168.1.1/24 broadcast 192.168.1.255 dev br0

Where tap0 connects to one virtual host and tap1 connects to the other virtual host. Both virtual host would be able to talk to one another via the bridging of tap0 and tap1 and they could talk to dom0 via br0.

Not sure if that is exactly what your going for but I use a similar configuration for GNS3 and QEMU... even if it doesn't apply here, knowing what TUN/TAP interfaces are and how to set them up is good to know when setting up virtual hosts. BTW never used xen, only qemu, so I am not 100% this would be all you need to do to get it up and working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.