Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a windows Server 2008 instance as a guest on KVM. When I tried to run it via virtual machine manager, the process got frozen after few seconds and trying to resume the process lead to this error from virt-manager:------

Error unpausing domain: internal error unable to execute QEMU command 'cont': Resetting the Virtual Machine is required

I tried to Reboot it without any success. Any help will be highly appreciated.


Edit 1:

/var/log/libvirt/qemu/vm2.log

KVM: entry failed, hardware error 0x80000021

If you're running a guest on an Intel machine without unrestricted mode support, the failure can be most likely due to the guest entering an invalid state for Intel VT. For example, the guest maybe running in big real mode which is not supported on less recent Intel processors.

share|improve this question
    
What Linux distribution and kernel version? –  Michael Hampton Nov 15 '12 at 5:00
    
Linux simah 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux Distributor ID: Ubuntu Description: Ubuntu 12.04 LTS Release: 12.04 Codename: precise –  mdoust Nov 17 '12 at 7:42
    
Edit your question and add in the relevant portion of the log files, which you can find in the /var/log/libvirt/qemu directory. –  Michael Hampton Nov 17 '12 at 15:50
add comment

3 Answers

up vote 0 down vote accepted

Congratulations, you've run into a kernel bug.

While Ubuntu is shipping a fixed kernel for 12.10, the fix has never been backported to 12.04 LTS. (And while reading the bug on launchpad, I could not figure out how to mark Precise as affected...)

share|improve this answer
    
Thanks for the information. Is there any fix available for 12.04? –  mdoust Nov 19 '12 at 7:39
    
I already said there wasn't. –  Michael Hampton Nov 19 '12 at 15:54
    
Thanks indeed for your cooperation :D –  mdoust Nov 22 '12 at 10:16
add comment

your problem happened to me then I try to solve it and I found that happened because KVM memory that I allowed to used from my computer and changed thee "ram from 512 MB allowed to 1024 MB allowed".

You can open virtual manager (virt-manager) and edit your physical KVM resource.

share|improve this answer
add comment

if you have intel metherboard, your problem related with that this motherboard have not SLIC-table in BIOS. maybe this links can help

http://uzlec.ru/vshivaem-tablicy-slic-v-linux-kvmqemubochs.html

http://code.coreboot.org/p/seabios/downloads/32/

share|improve this answer
1  
This doesn't appear to have any relevance to this problem. –  Michael Hampton Nov 7 '13 at 14:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.