Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

http://ec2-54-243-158-66.compute-1.amazonaws.com

I was following a tutorial and right after I did this, my server stopped responding:

sudo su

vi /etc/httpd/conf/httpd.conf

find the line:
AllowOverride None - after the (about line 339 or so...)

change to AllowOverride All (case matters! All not all or ALL)

:wq to save

service httpd restart

I reverted everything back to exactly what it was and it still wont work.

Edit: http://stephen-white.blogspot.com/2012/05/how-to-set-up-wordpress-on-amazon-ec2_31.html This was the tutorial I was following, everything worked until I made that change suggested by a comment at the bottom that allowed wordpress to modify the .htaccess for permalinks

share|improve this question
    
What do your logs say? –  ceejayoz Nov 6 '12 at 17:49
    
I personally don't know how to read system logs haha I uploaded it here: ec2-54-243-158-66.compute-1.amazonaws.com/log.txt –  Stephen Harman Nov 6 '12 at 17:58
    
Did you figure this out? I've installed WordPress and other PHP applications on AWS before many times with no issues. The comment on there for AllowOverride was relating to using a specific kind of permalink. Were you trying to enable that permalink format? –  Nathan V Nov 28 '12 at 15:03
    
your server isn't up so we can't read your logs. just look for error messages in the apache log file (all logs are in /var/log). If you like you can rename the current log file and restart apache to get a clean log which will make it easier to read. –  Drew Khoury May 8 '13 at 14:11

1 Answer 1

Hopefully you have figured this out by now, but I will share a very helpful command: httpd -S This will syntax check your configuration files for you. It may give you a clue as to why apache will not start. The /var/log/httpd/error_log should also have helpful information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.