Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

EDIT:

I finally got it working by specifying the folder. In the virtual host file in the sites-enabled I changed:

SVNParentPath /home/ant

To

SVNPath /home/ant/svn

and it finally worked!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Now to continue my plan for world domination!!! BWHAHHAAHA :)

Thanks to all the guys that helped out


Hey!

I have followed this ubuntu tutorial: https://help.ubuntu.com/9.04/serverguide/C/subversion.html

So I have svn, apache with webdava, the password file and www-data has access to the folder where the repository is located.

I really did follow the tutorial.

So I have the rep at /home/ant/svn and if I try to use the svn commands on the server machine they work.

But when I am on my windows machine and they to import or checkout I get this:

Server sent unexpected return value (403 Forbidden) in response to OPTIONS

I have googled for this and I can't seem to find a way to correct this.

Anyone know how to correct this? Thanks!

EDIT

The command I used that work was a 'svn co file:///path folder

I am trying to import a project I have via the tortoise menu

This is what I have in the apache error log

[Thu Jul 23 11:52:16 2009] [error] [client 192.168.1.100] Could not fetch resource information. [403, #0] [Thu Jul 23 11:52:16 2009] [error] [client 192.168.1.100] (2)No such file or directory: The URI does not contain the name of a repository. [403, #190001] [Thu Jul 23 11:52:16 2009] [error] [client 192.168.1.100] Could not fetch resource information. [403, #0] [Thu Jul 23 11:52:16 2009] [error] [client 192.168.1.100] (2)No such file or directory: The URI does not contain the name of a repository. [403, #190001] [Thu Jul 23 15:00:47 2009] [error] [client 192.168.1.100] Could not fetch resource information. [403, #0] [Thu Jul 23 15:00:47 2009] [error] [client 192.168.1.100] (2)No such file or directory: The URI does not contain the name of a repository. [403, #190001] [Thu Jul 23 15:41:21 2009] [error] [client 192.168.1.100] Could not fetch resource information. [403, #0] [Thu Jul 23 15:41:21 2009] [error] [client 192.168.1.100] (2)No such file or directory: The URI does not contain the name of a repository. [403, #190001]

EDIT:

Since I can't format comments (stupid thing) here's my reply to Swoogan

  1. It was: svn co file:///home/ant/svn lixo - I got a Checked out 0 (or something like that)
  2. http://192.168.1.2/svn
  3. sudo svnadmin create svn - And yes that is in my home/ant dir

Also I changed the webdav to /home/ant and got the same thing :(

share|improve this question
1  
First, you need to specify the exact command that you use on the server (that works) and the command that you use on the client. Second, look in the error logs for apache. It will give you more info about what was forbidden and why (tail /var/log/httpd/error_log) –  Swoogan Jul 23 '09 at 15:18

4 Answers 4

"The URI does not contain the name of a repository."

Whatever URL you are using (you still didn't provide it) is wrong. If your repo is in /home/ant/svn then your apache conf should look like:

<Location /svn>
  DAV svn
  SVNParentPath /home/ant/svn
  AuthType Basic
  AuthName "Your repository name"
  AuthUserFile /etc/subversion/passwd
  <LimitExcept GET PROPFIND OPTIONS REPORT>
  Require valid-user
  </LimitExcept>
</Location>

You should then be able to access (via web browser) the repo with

http://servername/svn/nameofrepo

That is assuming you created a repo inside /home/ant/svn. If the repo is called svn and is in /home/ant, then you want

<Location />
  DAV svn
  SVNParentPath /home/ant

and you would access with

http://servername/svn

Basically, I could give you the answer if you:

  1. Gave the exact command you used on the command-line that succeeded
  2. Gave the exact url you are using in Tortoise
  3. Gave the exact command you used to create the repo
share|improve this answer

This is probably too obvious, but you set up the password file, so are you using that username and password from tortoise? I don't have much experience with the workings of that, but 403 sounds like a permission issue.

share|improve this answer
    
Yes I am using the correct user name and password :( –  AntonioCS Jul 23 '09 at 14:42

Is your remote host allowed in the Apache config?

share|improve this answer
    
I tried to remove the Denny from All in the apache.conf. So it should have permission –  AntonioCS Jul 23 '09 at 17:31

Which SVN commands work on the server? I just want to make sure you used the svn:// url and not the file:// one.

If this is ok, can you access the svn port on the server? A simple telnet connection should suffice.

Update:
Try the 'svn co http://servername/svn' format on the server, with the same servername you use on the Tortoise machine. This seems to be a wrong configuration and not anything to do with Tortoise.

I usually just use the svn:// method - as explained under the "Access via custom protocol" section in the HowTo. It does have limitations, but I'm not sure of what your application is. Perhaps this is all you need.

share|improve this answer
    
I tried the svn co file:///path folder –  AntonioCS Jul 23 '09 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.