Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've added a VM in Hyper-V on Windows 8 Pro and created a Virtual Switch. The Virtual Switch is set to "Internal network".

On the host machine, I go to Control Panel > Network and Sharing Center > Adapter Settings and bridge the newly created "vEthernet" adapter and my existing (and working perfectly) Wi-Fi connection. Once Windows has finished configuring the bridge I lose connectivity on my host machine. What am I doing worng? What is the correct way to configure a network so that the VMs can get to the outside world?

I'm running RTM Windows 8 Pro (v6.2 build 9200).

Update
Creating an External network has exactly the same effect of killing my physical connection.

share|improve this question

closed as off-topic by Sven Jun 12 at 14:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Sven
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 2 down vote accepted

Stop trying to bridge the Virtual Switch adapter with ANY of the physical network adapters in the host. That's not how Hyper-V networking works and is no doubt the cause of your problems. The correct way to implement networking in Hyper-V for VM communication that needs to occur between the virtual machines and the rest of the external network (the network beyond the Virtual Switch) is to create an external Virtual Switch on one of the physical adapters on the host, preferably a NIC dedicated for Virtual Machine communication. If you only have a single NIC in the host then that can be used for both host communication and for VM communication, although it can't be a wireless NIC.

share|improve this answer
    
Then I guess it's the fact I'm trying to use my WiFi. –  Greg B Nov 7 '12 at 16:16

Internal network can only talk to each other and to the host. You can't connect such a vswitch to an Ethernet adapter. The correct option is to use an "external" vswitch type.

share|improve this answer
1  
that has the same effect of killing my network. –  Greg B Nov 7 '12 at 9:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.