Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have OpenSuSE 11.4 and Slackware 13.37. On both machines there is vpnc client. If I start vpnc connection is successfull, I can start work. After period of time (if there is no activity this period is around 10 minutes and if there is activity period is different every time) connection is "lost". I have no ping t0 the vpn network but 'ifconfig' show me the interface:

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:192.168.255.78  P-t-P:192.168.255.78  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1412  Metric:1
          RX packets:766 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1205 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:126464 (123.5 KiB)  TX bytes:111763 (109.1 KiB)

If I run 'show crypto session' on cisco router I receive that my connection is active:

Interface: Virtual-Access16
Username: XXXXX
Profile: XXXXXXX
Group: XXXXXX
Assigned address: 192.168.255.78
Session status: UP-ACTIVE     
Peer: xx.xx.xx.xx port 24228 
  IKE SA: local 192.168.1.2/4500 remote xx.xx.xx.xx/24228 Active 
  IPSEC FLOW: permit ip 0.0.0.0/0.0.0.0 host 192.168.255.78 
        Active SAs: 4, origin: crypto map

If I try to reconnect without manually issue disconnect I receive:

root@darkstar:~# vpnc server
vpnc: Error binding to source port. Try '--local-port 0'
Failed to bind to 0.0.0.0:4500: Address already in use
root@darkstar:~#

so my connection must be active but it is not :(. If I issue vpnc-disconnect and then vpnc server I am connected with new IP address and the problem continue to appear.

Vpnc info:

root@darkstar:~# vpnc --version
vpnc version 0.5.3
Copyright (C) 2002-2006 Geoffrey Keating, Maurice Massar, others
vpnc comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of vpnc under the terms of the GNU General
Public License.  For more information about these matters, see the files
named COPYING.
Built without openssl (certificate) support.

Supported DH-Groups: nopfs dh1 dh2 dh5
Supported Hash-Methods: md5 sha1
Supported Encryptions: null des 3des aes128 aes192 aes256
Supported Auth-Methods: psk psk+xauth

OS info:

root@darkstar:~# uname -a
Linux darkstar 3.5.0_core2_3_5 #5 SMP Fri Jul 27 09:40:39 EEST 2012 x86_64 Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz GenuineIntel GNU/Linux

Route table:

root@darkstar:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.5.1     0.0.0.0         UG    303    0        0 wlan0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
172.18.10.0     0.0.0.0         255.255.255.0   U     0      0        0 tun0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 tun0
192.168.5.0     0.0.0.0         255.255.255.0   U     303    0        0 wlan0
192.168.255.0   0.0.0.0         255.255.255.0   U     0      0        0 tun0
xx.xx.xx.xx     192.168.5.1     255.255.255.255 UGH   0      0        0 wlan0

172.18.10.0 is the network I reach by vpn

Is there someone who have the same problem and if there is - what is the solution?

share|improve this question
    
Does an SSH connection stay up thru the same router?! Have you tried connecting via a different one? It could be your router's model/firmware. –  Gaia Nov 7 '12 at 11:48
    
SSH connection freeze after I 'lost' connectivity. I test this from 2 different computers with linux. There is no such problem with windows cisco vpn client. –  botzko Nov 7 '12 at 12:09
    
2 different computers can't keep an SSH connection up when going thru the same router? Try thru a different router. Problem gone? Upgrade the firmware on the router or replace it. –  Gaia Nov 7 '12 at 13:08
    
May be I did not understand you. I connected 2 different computers to the vpn (not in the same time) and create ssh session to the server (server is in vpn network). I will try to connect two computers in the same time and to check if the problem will appear in the same time. I can not touch the router (have no rights to do this). –  botzko Nov 7 '12 at 13:18
    
Forget the VPN. Simply use any computer to SSH into any machine via the router you are currently using. If you can't keep the SSH connection up either the problem is the router. I am trying to simplify your diagnostics –  Gaia Nov 7 '12 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.