Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Today I was updating one of production server (one of many to test updates and then update the rest of computers).

Soon after run yum update ssh connection was broken :/ . After login once again using screen sesion this time I run yum-complete-transaction but it has problems so I run it with --skip-broken parameter. That worked fine for unfinished transaction but problem with perl dependency stays. I tried to reinstall perl package but it gives me an error :


Loaded plugins: langpacks, presto, refresh-packagekit
Installed package 4: perl-5.14.2-201.fc16.x86_64 (with updates) is not available.
Error: There is nothing to be done

This error I get trying to yum update:


Loaded plugins: langpacks, presto, refresh-packagekit
Dependency resolution
-> Running transaction check
---> Package perl.x86_64 4:5.14.2-201. FC16 is updated
-> Processing Dependency: perl = 4:5.14.2-201. FC16 for package: 1: perl-Pod-Escapes-1.04-201.fc16.noarch
-> Processing Dependency: perl = 4:5.14.2-201. FC16 for package: 4: perl-libs-5.14.2-201.fc16.x86_64
-> Processing Dependency: perl = 4:5.14.2-201. FC16 for package: perl-threads-1.83-201.fc16.x86_64
---> Package perl.x86_64 4:5.14.3-202. FC16 is updated
---> Package perl-CGI.noarch 0:3.52-201. FC16 is updated
---> Package perl-CGI.noarch 0:3.52-202. FC16 is updated
---> Package perl-Module-Pluggable.noarch 1:3.90-201. FC16 is updated
---> Package perl-Module-Pluggable.noarch 1:3.90-202. FC16 is updated
---> Package perl-PathTools.x86_64 0:3.33-201. FC16 is updated
---> Package perl-PathTools.x86_64 0:3.33-202. FC16 is updated
---> Package perl-Pod-Simple.noarch 1:3.16-201. FC16 is updated
---> Package perl-Pod-Simple.noarch 1:3.16-202. FC16 is updated
---> Package perl-macros.x86_64 4:5.14.2-201. FC16 is updated
---> Package perl-macros.x86_64 4:5.14.3-202. FC16 is updated
---> Package perl-parent.noarch 1:0.225-201. FC16 is updated
---> Package perl-parent.noarch 1:0.225-202. FC16 is updated
---> Package perl-threads-shared.x86_64 0:1.37-201. FC16 is updated
---> Package perl-threads-shared.x86_64 0:1.37-202. FC16 is updated
---> Package perl-version.noarch 3:0.88-201. FC16 is updated
---> Package perl-version.noarch 3:0.88-202. FC16 is updated
-> Complete dependency resolution
Error: package: 4: perl-libs-5.14.2-201.fc16.x86_64 (@ updates)
          Requires: perl = 4:5.14.2-201. FC16
          Removing: 4: perl-5.14.2-201.fc16.x86_64 (@ updates)
              perl = 4:5.14.2-201. FC16
          Updated by: 4: perl-5.14.3-202.fc16.x86_64 (updates)
              perl = 4:5.14.3-202. FC16
          Available: 4: perl-5.14.1-188.fc16.x86_64 (fedora)
              perl = 4:5.14.1-188. FC16
Error: Package: perl-threads-1.83-201.fc16.x86_64 (@ updates)
          Requires: perl = 4:5.14.2-201. FC16
          Removing: 4: perl-5.14.2-201.fc16.x86_64 (@ updates)
              perl = 4:5.14.2-201. FC16
          Updated by: 4: perl-5.14.3-202.fc16.x86_64 (updates)
              perl = 4:5.14.3-202. FC16
          Available: 4: perl-5.14.1-188.fc16.x86_64 (fedora)
              perl = 4:5.14.1-188. FC16
Error: Package: 1: perl-Pod-Escapes-1.04-201.fc16.noarch (@ updates)
          Requires: perl = 4:5.14.2-201. FC16
          Removing: 4: perl-5.14.2-201.fc16.x86_64 (@ updates)
              perl = 4:5.14.2-201. FC16
          Updated by: 4: perl-5.14.3-202.fc16.x86_64 (updates)
              perl = 4:5.14.3-202. FC16
          Available: 4: perl-5.14.1-188.fc16.x86_64 (fedora)
              perl = 4:5.14.1-188. FC16
 You could try using - skip-broken to work around the problem
** Found 6 pre-existing problems of the RPM database. The result of the command "yum check":
1: perl-Pod-Escapes-1.04-202.fc16.noarch is a duplicate 1: perl-Pod-Escapes-1.04-201.fc16.noarch
1: perl-Pod-Escapes-1.04-202.fc16.noarch has missing requirements perl = ('4 ', '5 .14.3', '202. FC16 ')
4: perl-libs-5.14.3-202.fc16.x86_64 is a duplicate 4: perl-libs-5.14.2-201.fc16.x86_64
4: perl-libs-5.14.3-202.fc16.x86_64 has missing requirements perl = ('4 ', '5 .14.3', '202. FC16 ')
perl-threads-1.83-202.fc16.x86_64 is a duplicate perl-threads-1.83-201.fc16.x86_64
perl-threads-1.83-202.fc16.x86_64 has missing requirements perl = ('4 ', '5 .14.3', '202. FC16 ')

(this is translated to english from my native language)

How to deal with it? (next time I will use screen for update system)

My system is Fedora 16 with 3.2.3-2.fc16.x86_64 kernel.

share|improve this question
add comment

2 Answers

Quickly run a yum clean all, followed by an RPM database check - rpm --rebuilddb - Then try again.

And you're right... Definitely use screen the next time you're running a critical or important system processes in the foreground on a remote session.

share|improve this answer
    
No that didn't help. Still the same error. –  B14D3 Nov 7 '12 at 12:48
    
Can you run a yum repolist? –  ewwhite Nov 7 '12 at 13:18
    
Yes I can :). Thx for your fast reaction :) –  B14D3 Nov 7 '12 at 13:30
add comment
up vote 0 down vote accepted

I manage to resolve deps by removing perl-libs, perl-threads, perl-Pod-Escapes. Removing this apps was easy (no dependency). After that yum update and everything is ok even removed apps was updated (there was a problem with some kind of duplicates I think).

Lesson for me use screen :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.