Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a SharePoint farm with two WFEs. I have 1 web app with anonymous access enabled and windows authentication and 1 site collection within the web app. I have extended the web app to internet zone using same windows auth mechanism and anonymous access to enable calls coming in on two different hostnames (abc123.com and www.abc123.com) using alternate access mapping.

When I access the original web app url (abc123.com) via either WFE it works fine When I access the extended web app url (www.abc123.com) on one box it redirects to /pages/default.aspx and works fine on the other WFE it fails with a 404 and doesnt redirect.

Any ideas what the problem could be or areas I could check? Cheers Russell

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Russ,

Barring additional information, my gut makes me think that IIS and web sites contained within may be involved. Have you gone into Internet Services Manager and confirmed that the (IIS) web site is present for the extended web application on the problem server?

If the site responds properly on one box but not the other, my suspicion is that you might be encountering issues with the SPAdmin service (that is, the Windows SharePoint Services Administration service). SPAdmin is responsible for carrying out tasks and jobs that originate at the Central Admin site on other servers within the farm. It does handle IIS-related provisioning operations, so if this service isn't running or is encountering problems on one of your WFEs, that WFE may not have been provisioned to handle the alternate URL.

In this situation, I'd also recommend having a look at the status of timer jobs (in Central Admin) to see if a provisioning operation for the box in question failed ... or is still pending. Recycling the timer service (SPTimerV3) certainly couldn't hurt as a low-impact, quick step.

If actions with these services produces no results, consider removing the web application extension and re-extending it to the zone in question again.

I hope this helps!

share|improve this answer
    
Cheers for the ideas. It works fine when is use the full page address (e.g. abc123.com/pages/default.aspx). It just fails when entering just the root address (e.g. abc123.com). I've checked that the website is present in IIS and has the correct hostname assigned to it. The SPAdmin service is running on both boxes. Timer jobs the only issues are: Quick Profile Synchronisation - Aborted Disk Quota Warning - Failed I tried restarting the timer service but the issue still occurs. I'll try re-extending the site on Monday. Cheers for the help, v appreciated! –  Russ Giddings Jul 24 '09 at 16:03
    
Hi there, I just tried reextending but I am still experiencing the same issue. Any other ideas? Also, can anyone confirm or refute that extending the web application the "best practice" recommended way of getting two hostnames to run the same application (www.abc123.com and abc123.com)? –  Russ Giddings Jul 27 '09 at 10:11
    
I think I'm putting two and two together; I just answered your related question re: extending web apps. This is just a hunch, but is there any chance that your default.aspx page is sitting in an unapproved or minor-only version? If you're surfing locally from one box, you could be transparently authenticating behind-the-scenes (since anonymous users will only see published and approved major versions) ... but when you go to the other box as a purely anonymous user (without behind-the-scenes authentication), you fail because you don't have the rights. Possibility? –  Sean McDonough Jul 28 '09 at 13:32
    
Additional check (and pardon me if you're well aware of this): when you enabled anonymous access on the extended zone, did you go in through that zone (via a user who was granted a Full Rights web application policy) to turn on anonymous access within the site collection? If you turned on anonymous access from Central Admin but didn't do so through the URL associated with the extended zone mapping to turn it on within the site collection, you won't be in a truly anonymous mode. –  Sean McDonough Jul 28 '09 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.