Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried installing mod_ssl,I used this command apt-get install mod_ssl to install but I got an error saying unable to locate package mod_ssl.

After executing the above command, I got below output

Reading package list.. Done
Build dependency tree
Reading state information done..
E:unable to locate package mod_ssl

How do I resolve it ?

share|improve this question
up vote 8 down vote accepted

Run the command dpkg -S Chances are that it will display something like:

apache2.2-common: /usr/lib/apache2/modules/

It means that mod_ssl is already installed on your system, as it does not come in a separate package, but it is bundled in apache2.2-common. Run

a2enmod ssl

to enable it, if it is not already enabled.

share|improve this answer
:Thank you,it worked.I'm trying to install SSL on my ec2,following this post but struck.In step 5 ,when i type cp server.crt /usr/local/apache/conf/ssl.crt ,i get an error saying no such dir or file.How to resolve this ? – user1263374 Nov 7 '12 at 15:54
That guide isn't meant for Ubuntu. It is instructing you to copy the server certificate into a folder that does not exist on your machine. You may want to follow or . Make sure to look carefully at what you specify in the configuration file for the SSLCertificateFile and SSLCertificateKeyFile directives, and copy the files into the right directories, with the right names. – pino42 Nov 7 '12 at 16:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.