Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

the admin installed a new file server in our institute: OpenSuse 11.1 with Samba 3.2.7-11.3.2-2154-SUSE-CODE11. They copied the smb.conf from the old machine (hosting Samba 3.0.0) to the new one.

Everything works as before, but one Windows 98 machine can see but not access the file server. It prompts for user authentication, but will not accept any user-password combination.

There exists a lot of discussion about the problem on the net, but none provided a clear answer to the problem.

EDIT:

  1. I changed Win98 registry enable plain-text passwords, and alternatively changed server's smb.conf and /etc/smbpasswd to accept encrypted passwords
  2. Further I provide a profile with a user-password combination on Win98 machine similar to one of the samba users-password combinations.
  3. I changed smb.conf such that the samba server is the Local Master Browser

All these changes are not necessary when using the older samba server. So, I conclude that a configuration problem on the server side is likely.

If you need any further information, I will post them here.

Best regards, Simon

share|improve this question

migrated from stackoverflow.com Jul 23 '09 at 14:40

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

Save the world from bad password protocols, and install the Active Directory Client Extensions for Windows 98 onto the client. It enables a wider, and vastly more secure, suite of password protocols that Samba 3.2 also supports. Two articles:

How to enable NTLMv2 on Win98:
http://support.microsoft.com/kb/239869

How to get the Client Extensions:
http://support.microsoft.com/kb/288358/

share|improve this answer
add comment

Did you try setting "lanman auth = YES" (without "") in the [global] section of the smb.conf? And try with "pdbedit -L username" if the user isn't locked out. (He is, when pdbedit shows only XXX for the password.) If so, set the password again with smbpasswd.

OH yeah.. And put "lanman auth = YES" as the first option directly AFTER the [global] to make it work permanently.

Oh and maybe "client lanman auth = YES" must be set too in your config.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.