Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

What is the best way to find out what files are sucking up so much space? My Windows directory lists its size as 15 GB but when I run a powershell script against it, it shows 40 GB. It seems 40 GB is about right because if I use that 40 GB and add it to the rest of my folders on C I get the 45 GB that is in use.

I checked volume shadow copy and that is disabled and there are no volume shadow files listed. My page file is limited to 3 GB. How can I find out what files are taking 25 GB of space?

Final Results: We ended up disabling UAC and then the Properties showed the true file size of the Windows folder, as shown in powershell script. This allowed us to drill down to the folder that had the issues... In our case it was in C:\Windows\System32\config\systemprofile\AppData\Local\VMware\VDM there were several large dump files, these were the mysterious unknown files in WinDirStat. It turns out our nessus scan is crashing a view service for a couple seconds so it creates a large dump file. So we will try this.. https://discussions.nessus.org/thread/5212

share|improve this question
    
Found the Unknown files in the logs. The security logs had been set to archive instead of writeover. Had to clear them here: C:\Windows\System32\winevt\Logs –  user260610 Dec 19 at 22:04

3 Answers 3

up vote 7 down vote accepted

WinDirStat is a good tool for visualizing filesystem usage on Windows volumes. It's helped me find "missing" space plenty of times before.

share|improve this answer
    
Thanks for the link. I tried this but WinDirStat is only showing what the properties shows of all the folders, total 19.2 GB instead of what the volume shows as in use, 43 GB. Any other suggestions? –  Xaxum Nov 7 '12 at 20:57
    
Ahh I think I see it. I checked show Unknown and there is a 23.3 GB file. There is my missing space. So now it becomes a question of knowing what that huge file is. –  Xaxum Nov 7 '12 at 21:01
1  
That's usually because of a file/folder structure that your current account doesn't have permission to. This is usually a Volume Shadow Service misbehaving or being turned on by someone else. Poking around with the vssadmin list commands should hopefully shed some light. –  MDMarra Nov 7 '12 at 21:04
    
listing shaows, shadowstorage, shows no files. I am at a loss to figure out what this file is. I logged in as admin and still the same result, unknown. –  Xaxum Nov 7 '12 at 21:16
    
@Xaxum Is the missing space your page file? –  ponsfonze Nov 8 '12 at 0:03

TreeSize visualizes your folder structure and the data density of each node. Helped me with the same problem uncounted times. Here´s a link to the website.

share|improve this answer

I've been using SpaceMonger for a while. Old ver. 1.4.0 is compatible with W2k3, W2k8. Requires no installation. Latest ver. does require installation.

Space Monger

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.