Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get sdparm working on a Solaris (Express 11) machine. I got it compiled, but stuck at figuring out the device name syntax to use when calling it. Trying something like

 /usr/local/bin/sdparm /dev/dsk/c11d0p0` 

just returns

SCSI INQUIRY command failed on /dev/dsk/c11d0p0

the same goes for /dev/rdsk/ locations.

What would be a device name sdparm would accept in a Solaris environment?

share|improve this question
What version of sdparm are you running? Can you try and run it with --verbose? –  pino42 Nov 7 '12 at 21:45
@pino42 I've downloaded and compiled the current 1.0.7 tarball. The --verbose option just adds >>> about to open device name: /dev/dsk/c11d0p0 to the output. –  the-wabbit Nov 7 '12 at 22:24
I would try c11d0s0 and c11d0s2, but this is just a shot. I have never used uscsi(7l), and its manpage is not giving me any obvious suggestion about how drivers should implement it. –  pino42 Nov 7 '12 at 22:46
@pino42 the notation using slice references instead of partitions unfortunately does not change matters - the output is identical compared to my previous attempts. –  the-wabbit Nov 7 '12 at 23:41
Well, I tried that on a box running Illumos and SATA disks on standard AHCI ports, and sdparm works like a charm, but only on rdsk devices (any partition will do), which you have already tried. Perhaps the controller driver you're using doesn't support it, or requires you to do something differently? –  pino42 Nov 7 '12 at 23:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.