Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to disable or bypass the "Welcome" screen I see when I'm using RDC to log in to a machine using saved credentials?

I have startup task which launches an RDP session automatically to localhost when the machine boots. This works, except that the remote desktop window stops and waits for an "OK" on the Welcome screen:

MACHINENAME-A.B.C.D(Server ID:Console 0)



This screen is preventing me from automating this login. Is there any way to get around it?


Here's the command line I'm currently using to launch it:

start /min C:\windows\system32\mstsc.exe c:\rdp\ServiceRunner.rdp

share|improve this question
Is you password saved the old way (in the rdp file) or the 'new' way? – Greg Askew Nov 7 '12 at 21:31
@GregAskew To answer you question, the password isn't saved in the RDP file. Regardless, I set both those fields to an empty string as per your suggestion and it now works perfectly, thanks! – mikebridge Nov 7 '12 at 21:47
up vote 3 down vote accepted

Check if you have these policies specified:

Interactive logon: Message text for users attempting to logon
Interactive logon: Message title for users attempting to logon

In gpedit.msc:

Computer > Windows Settings > Security Settings > Local Policies > Security Options

Registry values:

share|improve this answer

Run and type: gpedit.msc

Open these up:

+Windows Settings then +Security Settings then +Local Policies

Find Interactive Logon: Message text for users attempting to logon and leave it blank. Click Okay.

Find Interactive Logon: Message title for users attempting to logon and leave it blank.

Close policy editor log off, and log back on and that plague of a window will be gone! POOF!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.