Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a mostly-Windows guy tasked with setting up email on an Ubuntu 12.04 instance at AWS and hit the following error:

When I browse to Horde, after entering my administrative credentials, I get the error message:

A fatal error has occurred

imp is not activated.

Details have been logged for the administrator.

I am following the following, quite detailed guide

This is happening at Step 20, at the text Now fire up you web browser and navigate to your server at to verify that you can log in as the configured administrative mail user. (of course I used my actual domain).


  • Where is Horde logging the "details"?
  • Any thoughts on why this might happen? I found Google hits suggesting that php5-mcrypt might be missing, but I verified it is installed and up-to-date in my case.
share|improve this question
up vote 1 down vote accepted

A1: Check the apache error logs. Specifically, the error.log file.

A2: If you used the long conf.php on the linked page as a template, don't. Something in that file might be causing the issue. Just copy conf.php.dist in the same directory over conf.php, and modify conf.php as you need.

share|improve this answer
Yeah, it was something about the provided conf.php. – Eric J. Nov 8 '12 at 1:56
In my case, it was just a chrome extension causing it. Worked fine in Incognito and other browsers. – Nimbuz Dec 12 '14 at 5:43

Your problem is not HordeMail it's Dovecot!

Try to use these paths in /etc/dovecot/conf.d/10-ssl.conf

 ssl_cert = /etc/ssl/certs/ssl-cert-snakeoil.pem
 ssl_key = /etc/ssl/private/ssl-cert-snakeoil.key

the paths provided by the tutorial are wrong.

share|improve this answer

Careful following the instructions in These instructions are missing lines in many of the configuration files beginning in section 20 where you configure Horde. The script for file /var/www/config/conf.php is missing all lines past line 170. This leaves you with a partially-configured system that does not work.

share|improve this answer
Can you point to the correct instructions, or give them here? – mattdm Nov 12 '12 at 3:40
I'll email the author and see if he can post the updated files. I'll let you know what I find out. – Cecil Claspell Nov 12 '12 at 3:49

After following the guide and using the conf.php file provided, a solution that worked to get past this error was:

  • Use the conf.php.dist as the conf.php
  • Copy over the "sql" configuration section from the provided quite into the new conf.php
  • Follow the remaining guide
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.