Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Zimbra 8.0 running over Ubuntu work fine but i have a warning

postfix/postdrop[XXXX]: warning: mail_queue_enter: create file maildrop/XXXXX.XXXXX permissions denied

the problem is i have 800MB generated for this warning only in 4 days.

i've tryed

  • execute zmfixperms like superuser
  • execute zmfixperms -e like superuser
  • execute zmfixperms --extended like superuser
  • change owner/group queue_directory to postfix/postdrop
  • set full permissions (rwx) to queue_directory

and log still is growing

queue_directory: /opt/zimbra/data/postfix/spool

drwxr-xr-x root    root     /opt/zimbra/data/postfix/spool 
drwx------ postfix postdrop /opt/zimbra/data/postfix/spool/maildrop
share|improve this question
    
What are the permissions/ownership on the the public and maildrop directories? –  symcbean Nov 8 '12 at 14:58
    
public directories? –  rkmax Nov 8 '12 at 15:27
    
If you haven't done so already, make sure you've stopped the Zimbra services first as the Zimbra user, then run zmfixperms as sudo. –  nedm Nov 8 '12 at 18:08
    
yes i did it. always stop zimbra with su - zimbra -c "zmcontrol stop" before any change –  rkmax Nov 8 '12 at 18:57
add comment

1 Answer

I just ran into the same problem. Turns out that postdrop was still running as the zimbra user after having fixed permissions and restarting zimbra.

Bringing down zimbra and then killing the postdrop task fixed it:

$ sudo su -
$ service zimbra stop
$ killall postdrop
$ service zimbra start
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.