Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Prior to Event X, RDPing to Server 2003 always caused the user name appear blank and Login to be enabled, so you could pick to which domain you would log in. For us it's either local or our domain. Since a recent Event X a domain + user name is being suggested for every server and it's not the most recently used user name. If you remove it manually from RDP dialog, it's still being pre-populated for you, and then at the next available opportunity it returns into General/User name option of RDP dialog.

So user name field comes pre-populated and you cannot change to log in locally (only if you manually erase domain specifier - everything before \) - Log in to option is disabled by default. We did not do any changes to our domain or client machines, so I am suspecting some Windows update caused it (and this being Event X). Interesting fact - it does not consistently happen on all machines, and some can login to some servers fine, while other servers keep suggesting a default user name.

What could be that Event X and is there a way to fix it?

EDIT: I tried this - How to clear remote desktop connections history and specifically this part of it:

reg delete "HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\UsernameHint" /f

The problem still persists.

share|improve this question

closed as off-topic by Greg Askew, Ward, mdpc, Jim B, fuero Mar 20 at 9:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – Greg Askew, Ward, mdpc, Jim B, fuero
If this question can be reworded to fit the rules in the help center, please edit the question.

    
How is this a problem, exactly? – joeqwerty Nov 8 '12 at 16:31
    
@joeqwerty: It is not substituting the right user (the one you would normally use), all the time. I agree with the fact it is probably not a big deal, but it causes confusion for users, especially for those cases when they normally login locally to domain-enabled server. Now they cannot it (or so it seems). – Neolisk Nov 8 '12 at 16:34
    
@joeqwerty: To talk in business terms, it slows down the workflow of logging in to a server. Normal workflow - double-click on the server (we have a software to aggregate all connections in one interface) and enter your password. Your user name would be there already and it's one you used last time. So you only enter a password. Current workflow - you go to user name - change it and only then enter a password. And you do it every time for every server, which is counter-productive. – Neolisk Nov 8 '12 at 16:40
up vote 3 down vote accepted

The information of the last logged on user is stored at HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default and in the .RDP file.

Check your server to be sure nothing is set there; Remote Desktop Session Host Configuration -> RDP -> Log on Settings. (a blank would be set for you, not the first option in the RDP option ('Use client side authentification')

In any case you can hardcore the username in the .rdp. Edit the file with notepad, and add; (If the option is not set on your RDP's server as mentionned over)

UserName:s: | Indicates the user name of a person who can log on to the remote device.

Reference there

share|improve this answer

I had the same issue and couldn't find any answers so in case you're the next person with the issue this is how I solved it.

In the registry stored under hklm\system\controlset001\control\terminalserver\winstations\rdp-tcp there is a value called username. I just deleted that.

it also appeared under controlset002 so I cleared both.

share|improve this answer
    
Cleared both - did not work. Restarted - did not work. It appears my problem is elsewhere. Thanks for your feedback though. +1 – Neolisk Apr 3 '13 at 13:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.