Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the file once. And suddenly I noticed even without webserver running (service nginx stop) I can still reach the file.

How is this even possible ? No matter how many times I try, I can still reach the file and download it to full content. And there is no connection alive when I check using netstat --tcp and no traffic change in ifconfig

Tried renaming the file, still can download it. Also tried changing browser.

Is there a possibility that the ISP cached the file ?

note : the 10mg.test file is the cachefly test file that I downloaded to server using wget

UPDATE 1: Tried shutting down the server, Still can download the file...

UPDATE 2: Seems I can't reach the file anymore. Not sure if it's because the server is completely down and I gave it some time. Even if it was caused by any other running process, why I couldn't see any change in ifconfig TX/RX value, neither in netstat --tcp

UPDATE 3: After rebooting the server, I renamed the file name and used watch ifconfig to watch over TX rate. Then started downloading file with different browsers and devices, and still There is no change in TX rate after the file has been downloaded once.

share|improve this question

closed as off-topic by Chris S Dec 16 '13 at 16:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Chris S
If this question can be reworded to fit the rules in the help center, please edit the question.

shut the http server down and access the site from a device you have never accessed it from (ie your phone). if it still comes up you either have some sort of proxy cache server running or a second instance of an http server – scape Nov 8 '12 at 18:10

Assuming you control and there are no other webservers running on that machine, the only way you can still request any content from that server is if it has been cached somewhere between your computer and your server.

try adding some query information to that url, eg: 10mg.test?q=123 and see if it still works. if it does, then you could be requesting that file from another server then your own, or there is still some form of software running on your server.

share|improve this answer
No it doesn't work when using ?q=123. Also tried shutting down the server to make sure there is no other software involving. – xperator Nov 8 '12 at 18:01

This is probably because of your local browser cache.

share|improve this answer
I know that but I tried changing browser as I said in first post. – xperator Nov 8 '12 at 18:24

Its likely that nginx is still running. To find out, try:

service nginx status

You may need to use sudo to stop nginx

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.