Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having trouble with adding a 2nd LDAP server into the client configuration. If I configure the client to use just either one, it works fine. So I'm sure both CA certificates work.

I have tried using TLS_CACERT option in both /etc/pam_ldap.conf and /etc/openldap/ldap.conf, but it doesn't work. I get this error when I do an ldapsearch.

This is what I have currently configured.

uri ldaps://ldap.abc.com:636/
ssl no
tls_cacertdir /etc/openldap/cacerts
pam_password md5

The CA certificate in /etc/openldap/cacerts has been hashed by using openssl. I also tried adding a 2nd hash sym link with .1 at the end but no luck.

share|improve this question
    
What error? (You didn't actually post yours.) –  84104 Nov 9 '12 at 0:16
    
any luck? I am also trying the same. –  chandank Dec 8 '12 at 0:08

1 Answer 1

If you are using multiple ldap servers, sign the cert for all the LDAP servers with the same cacert. That way you only have to distribute only one cacert.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.