Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a smtp server on my domain (wixencafe.net), and i'm using postfix for that.

First thing is, postfix delivers emails coming from outside, that is, if i send an email from gmail.com to wixencafe.net, i get the email in my Mailbox/

Second thing is, if i send an email from wixencafe.net (from the server cli via mutt -f Maildir/) to gmail.com, i get it too, so i guess that means everything works fine.

Now, my problem is, if I try to send emails from my desktop (which is not on the same network than my server), it just doesn't work. From thunderbird, i get a delivery error, and from a telnet wixencafe.net 25 i get a timeout error.

Now here's my /etc/postfix/main.cf config, tell me if you need any other file...

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = wixencafe.net
myhostname = localhost
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
home_mailbox = Maildir/
# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = wixencafe.net, localhost.localdomain, localhost.localdomain, localhost
relayhost = 
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

## anti spam settings

smtpd_recipient_restrictions = reject_invalid_hostname,
        reject_unknown_recipient_domain,
        reject_unauth_destination,
        reject_rbl_client sbl.spamhaus.org,
        permit

smtpd_helo_restrictions = reject_invalid_helo_hostname,
        reject_non_fqdn_helo_hostname,
        reject_unknown_helo_hostname

Thanks...

EDIT : Found the answer here : http://forum.linode.com/viewtopic.php?p=53456&sid=7848e2ef010c93662255db67d5522aee , it was a simple problem of my home ISP blocking connections on port 25... Thanks, and good luck on your problem!

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Found the answer here : http://forum.linode.com/viewtopic.php?p=53456&sid=7848e2ef010c93662255db67d5522aee , it was a simple problem of my home ISP blocking connections on port 25... Thanks, and good luck on your problem!

share|improve this answer
add comment

Since you only have localhost in your "mynetworks", postfix may be rejecting emails coming from your desktop. Check the postfix error log for more information.

Add the network of your desktop to "mynetworks" in main.cf and try sending an email again.

share|improve this answer
    
Thanks for your answer, thought it was not the problem, and now i've found it thanks to this thread : forum.linode.com/… , the problem was that my home isp was blocking port 25. thanks for your help though! –  Wxcafe_ Nov 9 '12 at 2:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.