Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I need to recompile php on a Fedora server because I need to use the --enable-zip flag. When trying to install the devel package, I get the following message. This is after a 'yum clean all':

yum install php53-devel.x86_64
Loaded plugins: rhnplugin, security
rhel-x86_64-server-5                                                                  | 1.4    kB     00:00     
rhel-x86_64-server-5/primary                                                          | 4.9 MB     00:00     
rhel-x86_64-server-5                                                                             14161/14161
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53-devel.x86_64 0:5.3.3-13.el5_8 set to be updated
--> Processing Dependency: php53 = 5.3.3-13.el5_8 for package: php53-devel
--> Finished Dependency Resolution
php53-devel-5.3.3-13.el5_8.x86_64 from rhel-x86_64-server-5 has depsolving problems
  --> Missing Dependency: php53 = 5.3.3-13.el5_8 is needed by package php53-devel-5.3.3-13.el5_8.x86_64 (rhel-x86_64-server-5)
Error: Missing Dependency: php53 = 5.3.3-13.el5_8 is needed by package php53-devel-5.3.3-13.el5_8.x86_64 (rhel-x86_64-server-5)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Output of 'yum repolist':

# yum repolist
Loaded plugins: rhnplugin, security
repo id                                               repo name                                                                           status
rhel-x86_64-server-5                                  Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)                                   enabled: 14,161
repolist: 14,161
share|improve this question
    
Can you show the output of yum repolist? –  ewwhite Nov 9 '12 at 16:18
    
Added. See above. –  coding_hero Nov 9 '12 at 16:24

3 Answers 3

Make sure your Red Hat subscription for this machine is active. Not having an active subscription is usually the cause of this. (If it is active, call Red Hat.)

And if you're compiling your own version of PHP, you don't need to do any of this.

share|improve this answer
    
I assume it is. I installed other packages yesterday. –  coding_hero Nov 9 '12 at 16:23
    
What do you mean by "you don't need to do any of this"? –  coding_hero Nov 9 '12 at 19:28
    
If you're compiling PHP, you don't need to install this package first. –  Michael Hampton Nov 9 '12 at 19:37

If you've compiled your own PHP and it's an RPM package, either exclude the offending package from your YUM command (using --exclude=packagename) or just run an rpm installation of your newly-compiled PHP.

share|improve this answer
    
It's the php that was installed via yum. I haven't compiled my own yet. –  coding_hero Nov 9 '12 at 16:34

Use another repo for PHP and php-dev packages. I'd recommend to use atomic

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.