Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My network runs into intermittent slow downs every so often (enough to hurt employee productivity) Lately it seems to be much worse. I believe the QoS implementation from the network provider maybe what is causing the issue here but they are not helpful.

I think that the 90/9 for EF and AF41 could be to blame. Phones usually work fine when the slowness is happening.

I will explain what testing I have done below, if you wish to skip to the router config jump down.

When the network is slow, any pings to any outside entities show high latency +200-300 when the norm is 80 or lower. However pinging my switches and routers are all instantaneous, I also have an MPLS so when I ping over that to my Data-center during the awful slow traffic, they are perfect which makes be believe something else other than a slow ISP is to blame. Also when everyone packs up for the day and goes home, and I go in to test, everything returns to normal. I requested Bandwidth usage over business hours and they show anywhere from 30% to 50% bandwidth utilization which to me is fine. Also as I mentioned during this slow internet the VoIP phones work fine.

I have about 160 users using VOiP phones and an aloworx pbx. A lot of them also use VPN to various client networks that they do business with.

*Cisco router config:*

Interface: GigabitEthernet0/0, PLATFORM SGMII INTERFACE

!Interface: GigabitEthernet0/1, PLATFORM SGMII INTERFACE

!Interface: GigabitEthernet0/2, PLATFORM SGMII INTERFACE

!

!

no ipv6 cef

no ip source-route

ip cef

!

ip dhcp excluded-address 10.102.20.240 10.102.20.254

ip dhcp excluded-address 10.102.20.1 10.102.20.50

ip dhcp excluded-address 10.102.21.190 10.102.21.254

!

ip dhcp pool DATA

network 10.102.20.0 255.255.254.0

netbios-name-server 192.168.100.250 192.168.100.251 192.168.119.250 192.168.119.251

default-router 10.102.20.1

dns-server 10.201.40.43 10.201.40.44

!

no ip domain lookup

ip domain name yourdomain.com

multilink bundle-name authenticated !

!

class-map match-any voice-signaling

match ip dscp af41

match protocol sip

class-map match-any voice-traffic

match ip dscp ef

match protocol rtp

!

policy-map llq-policy

class voice-traffic

priority percent 90

set ip dscp ef

class voice-signaling

bandwidth percent 9

set ip dscp af41

class class-default

set ip dscp default

fair-queue

policy-map shape_policy

class class-default

shape average 20000000

service-policy llq-policy

!

interface GigabitEthernet0/0

description => Metro Eth to PAETEC

ip address DELETED 255.255.255.252

no ip redirects

no ip proxy-arp

duplex full

speed 100

no cdp enable

service-policy output llq-policy

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.10

description Voice VLAN

encapsulation dot1Q 10

ip address 10.102.10.1 255.255.255.0

no cdp enable

interface GigabitEthernet0/1.20

description Data VLAN

encapsulation dot1Q 20 native

ip address 10.102.20.1 255.255.254.0

no cdp enable

!

interface GigabitEthernet0/1.30 description Guest VLAN encapsulation dot1Q 30

ip address 10.102.30.1 255.255.255.0

ip access-group GUEST_ACCESS in

no cdp enable

!

interface GigabitEthernet0/2

description => Allworx WAN

ip address Deleted 255.255.255.252

no ip redirects

no ip proxy-arp

duplex auto speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3 ! interface Vlan1

no ip address

!

ip forward-protocol nd

!

no ip http server

ip http secure-server

!

ip access-list extended CORPORATE_ACCESS

permit ip 10.102.20.0 0.0.0.255 10.201.20.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 10.201.10.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 192.168.201.0 0.0.0.25

permit ip 10.102.20.0 0.0.0.255 10.201.0.0 0.0.255.255

permit ip 10.102.20.0 0.0.0.255 10.100.10.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 10.200.10.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 10.100.20.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 10.200.20.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 192.168.100.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 126.14.32.0 0.0.0.255

permit ip 10.102.20.0 0.0.0.255 192.168.98.0 0.0.1.255

permit ip 10.102.20.0 0.0.0.255 192.168.80.0 0.0.1.255

permit ip 10.102.20.0 0.0.0.255 192.168.119.0 0.0.0.255

deny ip 10.102.20.0 0.0.0.255 10.0.0.0 0.255.255.255

deny ip 10.102.20.0 0.0.0.255 192.168.0.0 0.0.255.255

permit ip any any

ip access-list extended GUEST_ACCESS

deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255

Another thing to note is that speeds tests usually show the full bandwidth for speed.

Any additional info needed I will provide, I really appreciate any help :O)

share|improve this question
    
Have you checked your DNS response? is a ping by name taking similar time than a ping by IP –  Pat Nov 11 '12 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.