Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a daemon program who need to read in a file who is saved somewhere in my home folder.

But every time I close my ssh connection, this daemon can't read the file because it appear that eCryptfs unmount the home.

Maybe there is an option to force eCryptfs to not only mount with an ssh connection ? I didn't found it.

Thanks.

PS : I know this thread, http://askubuntu.com/questions/165608/why-is-ecryptfs-only-mounting-private-home-directory-over-ssh, but this is not the proper/good way to deal with the request.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Remove auto-umount file from ~/.ecryptfs/ - each time you will need to umount your private directory manually. The other option is to keep your ssh session running using screen or tmux.

More info on ecryptfs Ubuntu

share|improve this answer
    
You mean : - keeping an ssh session on localhost inside screen ? Yes that should work. - removing auto-unmount still keep the system secure ? –  Bebeoix Nov 10 '12 at 13:09
    
Well, that depends on what kind of security you need. Generally it's always better to umount the directory when you're not using it. –  FINESEC Nov 10 '12 at 13:48
    
Ok and if I want the feature back, I just to re create a simple file "auto-umount" ? –  Bebeoix Nov 10 '12 at 15:12
1  
Yes, just create an empty file: touch ~/.ecryptfs/auto-umount –  FINESEC Nov 10 '12 at 15:34
    
Ok thanks you for your help ! –  Bebeoix Nov 10 '12 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.