Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up VDI across Windows Server 2012 VMs running on Hyper-V 2012.

The wizard's compatibility check for the Virtualization Host server failed with "Hardware-assisted virtualization is not present on the server".

I'm running an FX-8120 CPU and have the ASUS M5A97 motherboard.

I know I'm supposed to enable No-Execute (Hyper-V Hardware Considerations) but I cannot find that or any other synonyms of it in my motherboards UEFI BIOS (NX, XD, EVP, XN... nothing).

I found this:

PAE/NX/SSE2 Support Requirement Guide for Windows 8

which in short says "Windows 8 and Windows Server 2012 requires that systems must have processors that support NX, and NX must be turned on for important security safeguards to function effectively and avoid potential security vulnerabilities."

this leads me to believe NX is on by default if I was able to get this far and install Hyper-V 2012 and Windows Server 2012..

Also I tried to disable AVX in cmd with "bcdedit /set xsavedisable 1". Did not resolve

My processor is Zambezi FX-8120 and also supports RVI/SLAT/other synonym:

processor: Newegg Processor FX-8120

support proof: AMD Processors with Rapid Virtualization Indexing Required to Run Hyper-V in Windows 8

What's going on here? I bought this CPU specifically after I had the same problems with an older AMD Athelon II and made sure to buy one with AMD-V and RVI.

Thank you

EDIT: Here's a screenshot of my coreinfo output. It's strange that SVM option is available to set in my BIOS and yet coreinfo says it's not supported..

enter image description here

share|improve this question
The first thing you need to do is to buy a proper server. Or at least a proper server motherboard. – Michael Hampton Nov 11 '12 at 5:34
Can you say a little more? I know it's not a server board but for this small deployment I was trying to spend as little as possible to retrofit my current rig. What exactly am I looking for, the NX option? Some virtualization feature? How sure are you that it's the MB? Thank you – Vazgen Nov 11 '12 at 18:51
to be clear ms does not support nested virtualization with any motherboard\cpu combo. – tony roth Nov 20 '12 at 22:18
up vote 1 down vote accepted

It doesn't have much to do with your motherboard. (OK it might.) It has everything to do with your CPU though.


Hyper-V [2012] requires a 64-bit processor that includes the following:

Hardware-assisted virtualization. This is available in processors that include a virtualization option—specifically processors with Intel Virtualization Technology (Intel VT) or AMD Virtualization (AMD-V) technology.

Hardware-enforced Data Execution Prevention (DEP) must be available and enabled. Specifically, you must enable Intel XD bit (execute disable bit) or AMD NX bit (no execute bit).

Also SLAT.

Download coreinfo from Sysinternals. Run coreinfo.exe -v . It will tell you what you need to know.

enter image description here

Here's the technical data sheet for your processor:

Secure Virtual Machine (SVM,) as the nice gentleman in the comments pointed out, is on your processor, but it does not imply the XD or NX bit.

However I will concede that your motherboard could be responsible. If your motherboard is preventing you from changing that bit on the processor, then that's a problem.

Also make sure anything like "Enhanced Virus Protection" is turned on in your BIOS/EFI.

share|improve this answer
his motherboards supports both dep and slat! – tony roth Nov 15 '12 at 19:36
DEP and SLAT are not features of a motherboard. They are features of a CPU. And OP says in his post that he cannot locate an NX or XD (same thing) flag in his BIOS. Which is a show-stopper. – Ryan Ries Nov 15 '12 at 19:39
the nx or xd (dep settings) do not say nx or xd on there settings on most amd based MOTHERBOARDS. The cpu supports it just fine but you must enable the feature via the MOTHERBOARDS bios settings. The setting I think is labeled SVM. – tony roth Nov 15 '12 at 19:41
Here is the technical data sheet for the processor:… – Ryan Ries Nov 15 '12 at 19:58
You're right that you have to go through the motherboard's BIOS/EFI to set this bit, so you're right that his motherboard could be holding him back. So I've edited my post to reflect that. We're still discussing features of the processor though. – Ryan Ries Nov 15 '12 at 20:28

I have the same problem operating hyper-v to my windows server 2008 r2.0 x64. I have installed the same amd fx 8120 processor on asus m5a97 r2.0 motherboard. It took about 3 hours for installing server and did not support any motherboard driver to be installed on. whenever the driver disk was inserted, would receive the driver not supported by the operating system. I have checked the bios and have found svm is enabled, however is not supported on the server. I tried installing windows 7 x64 and was able to install within 30 minutes and it supported all the drivers on the disk which contained hydra vision for vitualization. Using hydra vision multiple virtual desktops can be created. It seems there is something in the motherboard driver that enables the virtualization and had to be installed on. Tried reaching ASUS support and was informed that they do not officially support server operating system to be installed on desktop. Have asked for any workaround for getting the virtualization activated but with no reply. This is ridiculous from the manufacturers side by restricting the capabilities of CPU.

share|improve this answer

Buddy I don't know if you still have this issue but I have the solution for you. I have the same setup and was breaking my head on this. Got this motheboard with new amd fx-8350 8core chips and was so frustrated when this problem came up. The motherboard I have to be exact is Asus M5A97 LE R2.0. The problem is that these motherboards have a new feature which is not supported by win2008 r2 yet. Not even with sp1. The result is the error that both of us were getting, vm's won't start in hyper-v. There is a hotfix for it that solves the issue. Check out microsoft support article below to download hotfix:

After you install hotfix reboot and problem is immediately fixed. I have my box on a ssd drive now and my vm's boot up in 4 seconds flat. sick. SICK

The update is on the processors and not the motherboad which is incompatible with win2008r2. the MOBO is fine. check out the article for an explanation but this is the def fix.

share|improve this answer
Thank you for getting back on this. Our setups are a bit different so I won't just assume this to work. I may give this another go sometime and if it works I'll come back and mark this as answer. Really appreciate it! – Vazgen Apr 11 '13 at 20:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.