Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup these values:

#skip-bdb
#skip-locking
#skip-innodb

When I add them to /etc/mysql/my.cnf and even if I turn ON of of, them after I do the service restart mysql fails to start, and no error message printed.

sudo service mysql restart
[ ok ] Stopping MySQL database server: mysqld.
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!

Previously I made sure that I have no InnoDB tables, and all files of that type were removed.

I tried looking for error files but I couldn't locate it:

  • /var/log/mysql.err is a 0 byte file
  • /var/log/mysql folder has no files

rsyslog was changed in past with inetutils-syslogd, and this might have changed the log files, and it could be the reason why I don't see any error logs, and I am stuck how to look or go forward.

share|improve this question
    
On debian, mysql logs to syslog, so check other files in /var/log too –  Dennis Kaarsemaker Nov 11 '12 at 10:46
    
You can stop mysql from using syslog by removing the file /etc/mysql/conf.d/mysqld_safe_syslog.cnf –  Dennis Kaarsemaker Nov 11 '12 at 10:51
    
OK I removed that and gave a try, and nothing visible on the screen, and files were not changed in the log directory –  Pentium10 Nov 11 '12 at 11:11

2 Answers 2

up vote 4 down vote accepted

The syntax has changed. Assuming you are trying to disable InnoDB so that you can use the MyISAM storage provider instead, here's how you do that. Instead of skip-innodb, put

innodb=OFF
default_storage_engine=MyISAM

in your /etc/mysql/my.cnf (under the [mysqld] section). Note that you need both: the new syntax for disabling InnoDB is innodb=OFF, but you also need to specify some other default storage engine to replace InnoDB. To verify that this has been successful, restart MySQL and run

mysqladmin -u root -p var | grep have_innodb

You should see the result

| have_innodb                                       | DISABLED              |

See also http://stackoverflow.com/a/11772814/781723.

I don't know what the equivalent is for skip-bdb or skip-locking.

share|improve this answer
    
This is correct for newer versions. I am using; Server version: 5.5.35-0+wheezy1 (Debian) –  Louie Miranda Feb 3 at 2:28

None of those options are available in current mysql packages. Having any of those would cause mysql to fail to start. If you want to see the error, you can run mysqld by itself by hand as root in a shell, and I'd expect to see it die when it encounters the first of these invalid options.

You can get a list of the available config parameters by running mysqld --help --verbose on the command line. mysqld --help --verbose | grep skip should also confirm that these options are no longer available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.