Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

What I want to do is to make my domain name resolve using my own nameservers.

I got 3 VPSes, all running debian and a domain name, mydomain.com

2 VPS are nameservers and 1 is a webserver.

At my registrar i've put my domain name to DNS only and changed the nameservers to my two own nameservers.

On my first nameserver I've installed Bind9 and configured as follows.

named.conf.local

zone"mydomain.com" {
type master;
file "/etc/bind/zones/mydomain.com.zone";
};

zone "x.x.x.x.in-addr.arpa" {
type master;
file "/etc/bind/zones/rev.x.x.x.x.in-addr.arpa";
};

/etc/bind/zones/mydomain.com.zone

mydomain.com. IN SOA ns3.mydomain.com. admin.mydomain.com. (
2006071801
28800
3600
604800
38400)

mydomain.com. IN NS ns3.mydomain.com.
mydomain.com. IN NS ns4.mydomain.com.
www           IN A  1.2.3.4 //my third VPS which is a webserver
ns3           IN A  x.x.x.x //this nameserver ip, should it be localhost?
ns4           IN A  x.x.x.x //my 2nd VPS nameserver ip
@             IN A 1.2.3.4

/etc/bind/zones/rev.x.x.x.x.in-addr.arpa

@ IN SOA ns3.mydomain.com. admin.mydomain.com. (
  2006071801; 
  28800; 
  604800; 
  604800; 
  86400); 

IN NS ns3.mydomain.com.
2 IN PTR mydomain.com

When i run nslookup www.mydomain.com the response is

Server: x.x.x.x //which points to the neighbourhood of my VPS provider
Address: x.x.x.x#53

Non-authoritative answer:
Name: www.mydomain.com
Address: x.x.x.x //this is the actual ip of my VPS webserver

So it seems to be working? I can't resolve via my webbrowser, am I just waiting for propagation or is there somethings missing?

Thanks in advance for any help or insightful advice.

share|improve this question
    
What's the domain? Can't really check for DNS brokenness if I don't know what to look for :) –  Dennis Kaarsemaker Nov 11 '12 at 18:26
    
epnddns.com is the domain :) –  Thuy Nov 11 '12 at 18:43
    
I edited my post to make things a bit clearer. –  Thuy Nov 11 '12 at 18:48
    
You should probably delete the whole in-addr.arpa stuff. Most VPS providers do not delegate you this tree so it's useless. –  bortzmeyer Nov 12 '12 at 8:43
add comment

2 Answers 2

up vote 2 down vote accepted

http://ip.seveas.net/dnsgraph/png/www.epnddns.com/?skip_.=on&show_A=Show

http://ip.seveas.net/dnsgraph/png/epnddns.com/?skip_.=on&show_A=Show

So ns3 is working correctly, but ns4 is not responding. You also forgot to add an A record for the domain. Something like:

@           IN A  x.x.x.x //my third VPS which is a webserver

The @ means: the domain, not a subdomain of it.

share|improve this answer
    
So basiclly i need to add @ IN A x.x.x.x so I have a www IN A 1.2.3.4 and @ IN A 1.2.3.4 record? Also fixing the ns4 server, gimme a sec :) –  Thuy Nov 11 '12 at 19:04
    
Okay I edited my inital post to reflect my change with the @ record. I copied my settings to ns4, restarted bind and the nslookup gives me the same result as ns3 now. Does things seem correct now? –  Thuy Nov 11 '12 at 19:22
    
All looks ok now :) –  Dennis Kaarsemaker Nov 11 '12 at 19:48
    
Awesome! Thanks a lot for the help and that webpage it looks rather helpful, it works perfectly now :) –  Thuy Nov 11 '12 at 20:10
add comment

Also, for a list of online tools to test your DNS zone, see http://www.bortzmeyer.org/tests-dns.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.