Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i am afraid that i broke somthing in my vps :/ i hope you can help me.

i am on ubuntu-12.04-x86. and i moved to new vps so i tryied to upgrade the php to the news version from 5.3 to 5.4. anyway after installing i get this messages:

fild loading /usr/lib/php5/20090626+lfs/ioncube_loader_lin_5.3.so /usr/php5/20090625+lfs/ioncube_loader_lin_5.3.so: undefined synbol: php_body_wri 
php 5.4.8-1~presise+1 (cli) (built(oct 29 2012)

i need to mention that the server is working and php also working but when i do phpinfo there is no

"with the ionCube PHP Loader v4.0.14, Copyright (c) 2002-2011, by ionCube Ltd."

which was before :/ i installed with this guide:http://www.upubuntu.com/2012/03/how-to-upgrade-install-php-540-under.html

i need to worry?

edit ok so think i found the solution inspired by Devator answer i downloaded the last ioncube from their website in zip file. in this zip file i found the file ioncube_loader_lin_5.4.so than i uploaded the file to the folder where i saw php looking for the 5.3 version eg:"/usr/lib/php5/20090626+lfs/", than i go to my php.ini file and put the line but it didnt work so i saw file 00-ioncube-loader-5.3.ini in conf.d folder in there i saw the line zend_extension=/usr/lib/php5/20090626+lfs/ioncube_loader_lin_5.3.so i edited to zend_extension=/usr/lib/php5/20090626+lfs/ioncube_loader_lin_5.4.so restart apache and now i saw the line where php info

'This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.'

sorry for bad english :/ problem solved i think so

share|improve this question
    
Did you add zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.4.so to your php.ini or is it present? –  Devator Nov 11 '12 at 22:20
    
i tryied now to add it, and restart the server. not help tnx –  amir Nov 11 '12 at 22:27
    
i searched and there is no file ioncube_loader_lin_5.4.so there is only: ioncube_loader_lin_5.3.so ioncube_loader_lin_5.2.so ioncube_loader_lin_5.1.so –  amir Nov 11 '12 at 22:57
    
@Devator Since that appears to be the answer, you should probably post it as such. –  Michael Hampton Nov 11 '12 at 23:43
    
@MichaelHampton Done, didn't want to mess up the answers if it didn't was the answer. Felt like it should be a comment, but as it's the answer I made an.. answer! :) –  Devator Nov 12 '12 at 0:04

3 Answers 3

up vote 1 down vote accepted

Did you add zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.4.so to your php.ini or is it present?

share|improve this answer

In case anyone else has the same case:
After checking Devator's solution, be sure that php is compiled with the following two flags:
--disable-maintainer-zts
--disable-safe-mode
or rather that these flags are NOT present:
--enable-maintainer-zts
--enable-safe-mode
If running WHM, these can be written in the Raw Opts file documented here:
https://documentation.cpanel.net/display/EA/Raw+Opts

share|improve this answer

I had the same issue after upgrading to PHP 5.4 on Ubuntu 14.04 following this tutorial: http://phpave.com/upgrade-php-5-3-php-5-5-ubuntu-12-04-lts/

You just need to run the following after the instructions above.

dpkg-reconfigure php5-ioncube-loader
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.